Results 1 to 10 of 10
  1. #1
    Join Date
    Aug 2007
    Posts
    263

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 24 by

    1 of my client website always got this error.

    may i know how to fix it?

  2. #2
    Join Date
    Sep 2010
    Location
    /usr/bin/fail
    Posts
    857
    increase memory_limit in your php.ini should cure it.
    JAXVPS Web Hosting Solutions - http://www.jaxvps.com
    Offering Premium SSD Shared, Reseller, and VPS Hosting Since 2010
    VPS servers available in both Jacksonville and Chicago locations

  3. #3
    Join Date
    Dec 2007
    Location
    Indianapolis, Indiana USA
    Posts
    15,200
    Quote Originally Posted by seachen View Post
    1 of my client website always got this error.



    may i know how to fix it?
    Contact your provider and ask them to raise the memory limit or to advise you on how to go about doing so on your own.
    Michael Denney - MDDHosting, LLC - Professional Hosting Solutions
    LiteSpeed Powered - Shared, Premium, Reseller, and VPS
    For high-end shared accounts ideal for business, check out our Premium offerings!
    http://www.mddhosting.com/ - Providing Quality Services since 2007

  4. #4
    Join Date
    Aug 2007
    Posts
    263
    now is as below:

    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)
    what is the suggested value?

  5. #5
    Join Date
    Sep 2010
    Location
    /usr/bin/fail
    Posts
    857
    you might try doubling that given that your file size is 33megs, but I assume that once its uploaded something is trying to either convert or compress the file similar to the way wordpress does when you upload a file.

    128megs was enough for me on my system when uploading up to a 15 meg jpg image so you might need a little more..
    JAXVPS Web Hosting Solutions - http://www.jaxvps.com
    Offering Premium SSD Shared, Reseller, and VPS Hosting Since 2010
    VPS servers available in both Jacksonville and Chicago locations

  6. #6
    Join Date
    Aug 2007
    Posts
    263
    I have double it to 256M.

    But it seen like remain same. Is it script problem?

  7. #7
    Join Date
    May 2008
    Location
    Melbourne, Australia
    Posts
    10,474
    Sounds like poor coding to myself, a good script would not require excessive use of memory. You could try increasing it to 512MB as a test, though, not something I would highly recommend.
    l Clever Emu (Twitter) Shared Reseller Cloud VPS Since 2003
    l Leading UK and Ireland Hosting Provider Multiple locations - around the globe!
    l cPanel/WHM R1Soft Backups 24/7/365 Support 99.9% Uptime Guarantee
    l www.yourcompanynamehere.com Customer Service Rep. Superior Service Guarantee

  8. #8
    Join Date
    Feb 2008
    Location
    Houston, Texas, USA
    Posts
    2,873
    Quote Originally Posted by seachen View Post
    I have double it to 256M.

    But it seen like remain same. Is it script problem?
    The script itself could be settings the value. Search your directory for a php.ini file or ini_set('memory_limit', xxx) like this:

    Code:
    grep memory_limit -r /home/ex_dir/public_html |grep ini_set
    OR

    Code:
    find /home/ex_dir/public_html -type f -name 'php.ini'
    Regards
    Joe / UNIXY
    UNIXy - Fully Managed Servers and Clusters - Established in 2006
    [ cPanel Varnish Nginx Plugin ] - Enhance LiteSpeed and Apache Performance
    www.unixy.net - Los Angeles | Houston | Atlanta | Rotterdam
    Love to help pro bono (time permitting). joe > unixy.net

  9. #9
    Join Date
    Dec 2007
    Location
    Indianapolis, Indiana USA
    Posts
    15,200
    If I'm not mistaken WordPress does actually set the memory_limit itself, I forget which file (and I don't have a console handy at the moment to check).

    At any rate, you can either just comment the line out or adjust it in the file.
    Michael Denney - MDDHosting, LLC - Professional Hosting Solutions
    LiteSpeed Powered - Shared, Premium, Reseller, and VPS
    For high-end shared accounts ideal for business, check out our Premium offerings!
    http://www.mddhosting.com/ - Providing Quality Services since 2007

  10. #10
    Join Date
    Sep 2010
    Location
    /usr/bin/fail
    Posts
    857
    The file that WP uses is the wp-settings.php file.


    Not sure if he is using WP as his script but there might be a similar item in his script to do it as well.
    JAXVPS Web Hosting Solutions - http://www.jaxvps.com
    Offering Premium SSD Shared, Reseller, and VPS Hosting Since 2010
    VPS servers available in both Jacksonville and Chicago locations

Similar Threads

  1. Fatal error: Allowed memory size
    By sanjai1977 in forum Programming Discussion
    Replies: 3
    Last Post: 05-08-2010, 03:34 PM
  2. Allowed Memory Size of ___ bytes exhausted
    By Necroist in forum Hosting Security and Technology
    Replies: 3
    Last Post: 04-05-2006, 11:08 AM
  3. php - Fatal Error: Memory size exhausted
    By Georgecooldude in forum Programming Discussion
    Replies: 7
    Last Post: 08-22-2004, 10:34 AM
  4. Allowed memory size of 8388608 bytes exhausted.....
    By Jet Blast in forum Programming Discussion
    Replies: 6
    Last Post: 08-07-2004, 05:22 AM
  5. Fatal error: Allowed memory size
    By Ivan23 in forum Programming Discussion
    Replies: 4
    Last Post: 02-05-2003, 10:48 PM

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •