Results 1 to 17 of 17

Thread: ssh daemon

  1. #1

    ssh daemon

    hey how do i install "ssh daemon" or any ftp googled it but cant find a guide(found 1 but dont work!)

    i dont have a controlpanel

  2. #2
    Join Date
    Mar 2009
    Location
    /usr/bin/perl
    Posts
    971
    If you're on a *nix (e.g. linux or *BSD) chances are an ssh server is installed by default.

    What OS are you on and what, specifically, are you trying to do?
    Ask me about CloudCentrum (coming soon) -- The complete, turn-key cloud software solution

  3. #3
    im with ramhost
    useing os Ubuntu
    and i have ssh
    i just need to send files to the server thats all like ftp

  4. #4
    Join Date
    Mar 2009
    Location
    /usr/bin/perl
    Posts
    971
    You're looking for "sftp" which should be enabled by default.

    login from a graphical client like filezilla, or from a terminal session, with the same credentials you would use to login via SSH, and the same port.
    Ask me about CloudCentrum (coming soon) -- The complete, turn-key cloud software solution

  5. #5
    im useing filezilla what port do i use?
    host :vps ip or vps Host Machine ip?
    port:??

  6. #6
    Join Date
    Mar 2009
    Location
    /usr/bin/perl
    Posts
    971
    Unless you changed something, the port would be 22.

    Use the same IP you presumably got in your welcome email, and the same one you've been using to login to SSH.
    Ask me about CloudCentrum (coming soon) -- The complete, turn-key cloud software solution

  7. #7
    Join Date
    Feb 2004
    Location
    USA
    Posts
    1,571
    Not sure filezilla has sftp support you may try a different client like coreftp - www.coreftp.com

  8. #8
    Join Date
    Mar 2009
    Location
    /usr/bin/perl
    Posts
    971
    Quote Originally Posted by TheServerExperts View Post
    Not sure filezilla has sftp support
    It definitely has sftp support
    Ask me about CloudCentrum (coming soon) -- The complete, turn-key cloud software solution

  9. #9
    when i try to connect i get
    220 (vsFTPd 2.0.6)
    Command: USER nxsxxxxxxx
    Response: 530 This FTP server is anonymous only.
    Error: Could not connect to server

  10. #10
    Join Date
    Nov 2005
    Location
    Michigan, USA
    Posts
    3,872
    Look up the logs, probably somewhere in /var/log look for ftp and see what the error is.


  11. #11
    http://www.linuxhomenetworking.com/w...p#Types_of_FTP[/QUOTE]

    if you go to mid of the page at topic "The vsftpd.conf File"
    it says:
    VSFTPD allows only anonymous FTP downloads to remote users, not uploads from them. This can be changed by modifying the anon_upload_enable directive shown later.
    VSFTPD doesn't allow anonymous users to create directories on your FTP server. You can change this by modifying the anon_mkdir_write_enable directive.
    VSFTPD logs FTP access to the /var/log/vsftpd.log log file. You can change this by modifying the xferlog_file directive.
    By default VSFTPD expects files for anonymous FTP to be placed in the /var/ftp directory. You can change this by modifying the anon_root directive. There is always the risk with anonymous FTP that users will discover a way to write files to your anonymous FTP directory. You run the risk of filling up your /var partition if you use the default setting. It is best to make the anonymous FTP directory reside in its own dedicated partition.
    dont know how to disable anonymous (from what i understand)
    devonblzx im new to this so i have no idea how to i typed in /var/log and i get bash: /var/logs: No such file or directory

  12. #12
    Join Date
    Nov 2005
    Location
    Michigan, USA
    Posts
    3,872
    cd /var/log; ls -l | grep ftp


  13. #13
    Quote Originally Posted by devonblzx View Post
    cd /var/log; ls -l | grep ftp
    -rw------- 1 root root 1915 Nov 15 07:49 vsftpd.log

  14. #14
    Join Date
    Sep 2009
    Posts
    1,794
    To install the "ssh daemon" please use thie commend -> "apt-get install openssh" after that start the service, and use winscp to connect to the server using sftp. You can download it here -> http://winscp.net/download/winscp424setup.exe Also this protocol is much secure than FTP because the transfer in encrypted.
    LVPSHosting.com|Virtual Private Servers|Dedicated Servers|
    Managed Hosting Solution|24/7/365 Support
    Datacentar and servers location: Holland, Europe

  15. #15
    Join Date
    Mar 2004
    Location
    /dev/null
    Posts
    275
    Quote Originally Posted by dbz_195 View Post
    when i try to connect i get
    220 (vsFTPd 2.0.6)
    Command: USER nxsxxxxxxx
    Response: 530 This FTP server is anonymous only.
    Error: Could not connect to server
    Make sure that you select SFTP as server type in the site manager.

  16. #16
    Join Date
    Nov 2009
    Location
    Houston Tx
    Posts
    108

  17. #17
    Yes filezilla should be able to do this. If you select sftp as the protocol and then use your ssh port as the port. Make sure you do not do anonymous login with filezilla enter your credentials.

    If your home machine is linux/mac open up a terminal and:

    sftp <user>@<ip>:<ssh port>

    and that should do it for you. If you have ssh enabled by default most commonly sftp is as well. You should be all set otherwise if the above posts didn't lead you anywhere contact your host support.

Similar Threads

  1. How to start ssh daemon
    By gazatem in forum VPS Hosting
    Replies: 8
    Last Post: 05-26-2009, 09:52 AM
  2. avahi-daemon
    By petfut in forum Dedicated Server
    Replies: 1
    Last Post: 02-27-2008, 05:36 AM
  3. who to config ssh daemon
    By Behrooz_Ice in forum Hosting Security and Technology
    Replies: 3
    Last Post: 08-15-2005, 03:29 PM
  4. daemon script
    By =-D in forum Programming Discussion
    Replies: 13
    Last Post: 02-20-2005, 09:33 AM
  5. pop3 daemon
    By cloede in forum Web Hosting
    Replies: 1
    Last Post: 11-18-2001, 03:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •