Results 1 to 6 of 6
  1. #1

    FTP.exe Fails silently on new VPS setup

    (I'm not sure this is the right place for this post, please move it if I've made a mistake!)

    I'm a dreamhost customer who upgraded to their VPS service about a month ago. I have this backup hack that has worked pretty well:

    (On Saturday Evening)

    CRON job to tar the files from each of my sites on the account, and place the tars in a special archive folder

    CRON job to dump the databases from each of my sites and tar them too, putting them all in the same backup folder

    (On Sunday Morning)

    BAT file on my computer that fires ftp.exe with the following script:

    open [my IP]
    [shell user name]
    cd backups/
    mget archives/
    mdelete archives/

    Simple, and it has worked really well until about a month ago. I checked to make sure everything was running correctly, and found that on my local machine, the archives stopped around the beginning of the Oct, which is when I upgraded.

    So I went in and checked a few obvious things:

    The IP address in the script was the right one. Check.

    User and pass are correct? Check, I use the IP/user/pass combo in FileZilla to connect via SFTP practically every day, and those settings all match.

    The CRON jobs are actually running. Check -- the archive files for the missing month are sitting undisturbed in the backup folder on the server,so the CRON jobs are running like they should be.

    My shell user is set up to be able to use ftp. Check, I can do it via FileZilla.

    I know the ftp script has executed because I've seen it run (and have to manually close the cmd window when it finishes), but just in case, I try to manually execute the ftp script, since that looks like that's what's failing. I run it, it connects without error, cds into the right directory without error, it mgets, then mdeletes, then exits, without error... but nothing actually happened: the files are still on the server, and nothing new in on my local machine.

    Also, while there was a delay in the mget and mdelete, I don't think it was long enough to actually download the 600 or so megs I had out there. I think it was long enough to have been some kind of timeout setting like 120 seconds or something. But it's puzzling the script doesn't show any errors -- it SAYS it's doing everything, and not indicating a problem. If it were a timeout, I wouldn't be getting 200s back, right?

    So I e-mail support, and they tell me the settings now are identical to the settings I had when I was on the shared system, so they don't know what the problem is.

    I'm not a server guy, I'm totally stumped here... can anyone point me in the right direction?

  2. #2
    I'm still not having any luck getting this to work... no one has any ideas at all?

  3. #3
    Join Date
    Feb 2004
    Do you have a static IP at home?

  4. #4
    Actually, [my IP] meant [my server's IP], and yes, that IP is static.

  5. #5
    Join Date
    Feb 2005
    A guess: Perhaps your new VPS is allowing anonymous logins. ftp.exe isn't as smart as FileZilla so it might be logging in anonymously and not prompting for (or ignoring) the user - pass you provide.

    Anyway, run the ftp commands interactively at a dos prompt - you may get a better idea of what's happening.

    "Some problems are so complex that you have to be highly intelligent and well informed just to be undecided about them." - Laurence J. Peter

  6. #6
    Interesting thought -- I did what you said. That didn't seem to help. I attached a shot of what happened. There was, again, a pause when I issued the mget command, but it wasn't long enough to get all the files in that directory. I also tried specifying the port, but that was just a shot in the dark which didn't work. (see screen shot)

    I also did a full search on my computer -- I thought maybe something changed such that the file was being downloaded but it was sitting somewhere else like the system32 folder. That turned out no to be the case -- I let windows scan my whole computer for the files, and it only found them in my backups folder, where I put them manually.

    This is nuts... how do other people do this? What are my other automatic backup options?
    Attached Thumbnails Attached Thumbnails ftp_scrn.png  

Similar Threads

  1. FTP fails please help
    By netpox in forum Dedicated Server
    Replies: 9
    Last Post: 06-26-2008, 01:04 AM
  2. yum update fails , easyapache also fails [cent os]
    By navyseal in forum Hosting Security and Technology
    Replies: 7
    Last Post: 04-22-2007, 02:39 AM
  3. Setup apache/ftp/mysql on VPS
    By Xlegged in forum Employment / Job Offers
    Replies: 5
    Last Post: 06-04-2006, 01:13 PM
  4. FTP fails with APF running
    By Nechochwen in forum Hosting Security and Technology
    Replies: 15
    Last Post: 01-28-2006, 05:28 PM
  5. Problems with setup.exe file
    By Bluegirl in forum Web Hosting Lounge
    Replies: 2
    Last Post: 10-12-2004, 06:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts