Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2009

    FTP Service problem.. Times out when trying to get directories

    For some reasons I cant access any of my accounts on my dedicated server via FTP. It simply times out when it tried to display the directories.

    Heres a log from FileZila...

    Status:	Resolving address of
    Status:	Connecting to
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [TLS] ----------
    Response:	220-You are user number 3 of 50 allowed.
    Response:	220-Local time is now 19:39. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	USER testaccount
    Response:	331 User testaccount OK. Password required
    Command:	PASS ********
    Response:	230-User testaccount has group access to:  testaccount
    Response:	230 OK. Current restricted directory is /
    Command:	SYST
    Response:	215 UNIX Type: L8
    Command:	FEAT
    Response:	211-Extensions supported:
    Response:	 EPRT
    Response:	 IDLE
    Response:	 MDTM
    Response:	 SIZE
    Response:	 REST STREAM
    Response:	 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Response:	 MLSD
    Response:	 ESTP
    Response:	 PASV
    Response:	 EPSV
    Response:	 SPSV
    Response:	 ESTA
    Response:	 AUTH TLS
    Response:	 PBSZ
    Response:	 PROT
    Response:	211 End.
    Status:	Connected
    Status:	Retrieving directory listing...
    Command:	PWD
    Response:	257 "/" is your current location
    Command:	TYPE I
    Response:	200 TYPE is now 8-bit binary
    Command:	PASV
    Response:	227 Entering Passive Mode (64,237,58,43,145,153)
    Command:	MLSD
    Response:	150 Accepted data connection
    Response:	226-ASCII
    Response:	226-Options: -a -l 
    Response:	226 18 matches total
    Error:	Connection timed out
    Error:	Failed to retrieve directory listing
    I have restarted the FTP service serveral times but still It doesnt loads.

  2. #2
    Join Date
    Oct 2009
    Try to restart the FTP service and make sure that the file and folder permissions are correct.
    Also check the log tail -f /var/log/messages.
    /etc/init.d/pure-ftpd restart
    Last edited by ramsh; 11-09-2009 at 03:58 PM.

  3. #3
    Quote Originally Posted by ihavenoidea View Post
    For some reasons I cant access any of my accounts on my dedicated server via FTP. It simply times out when it tried to display the directories.
    The reason is the Ftp modules are not loaded in the kernel. Login to the server as root and execute:

    /sbin/modprobe ip_conntrack
    /sbin/modprobe ip_conntrack_ftp

    This will load the modules that are responsible to keep track of Ftp connections. Disconnect the current Ftp session and start a new one.
    | Server Setup | Security | Optimization | Troubleshooting | Server Migration
    | Monthly and Task basis services.
    | MSN : madaboutlinux[at] | Skype : madaboutlinux

  4. #4
    Join Date
    Sep 2009
    I've tried the restart commands, still nothing.

    Using the conntrack command I can see there is three connections. How can i end them all?

  5. #5
    Join Date
    Sep 2009
    I have found that this problem only arises when my server is hitting peak times (which still only uses 1.0 of 4 cores and only 40% of 4GB ram).
    Can anyone figure out why its not working during peak times?

  6. #6
    Join Date
    Apr 2009
    did u check if the port series are added in the firewall ingress port? the port (other than 21,22) check for the port range in ftp conf and add it in the ingress port in firewall and restart both. this should solve the issue.

  7. #7
    Join Date
    Jan 2001
    Miami, FL
    check and make sure the active / passive ports are open through your firewall
    Biznesshosting, Inc. DBA VOLICO - Intelligent Hosting Solutions
    East Coast Enterprise Dedicated Servers and Miami Colocation.
    managed and unmanaged dedicated servers. High bandwidth colocation. Managed clusters.

  8. #8
    Join Date
    Jul 2007
    You will have to connect through active method and not passive method.
    Prashant T.

    Don't run after Success. Run after Excellence and Success will soon follow.

Similar Threads

  1. 1000 directories submission service : 55$
    By BonsaiRack in forum Other Offers & Requests
    Replies: 3
    Last Post: 10-29-2007, 02:41 PM
  2. 100% Manual Submission Service to 250 Free Directories For $49.
    By senaia in forum Other Offers & Requests
    Replies: 0
    Last Post: 01-26-2007, 05:27 AM
  3. Manual Submission Service to Over 250 Free Directories
    By senaia in forum Other Offers & Requests
    Replies: 0
    Last Post: 10-19-2006, 01:50 AM
  4. SubDomain Problem - Directories?
    By Quincy Wisdom in forum Hosting Software and Control Panels
    Replies: 2
    Last Post: 07-06-2004, 09:35 AM
  5. error when ftp' on server
    By nachopo in forum Hosting Security and Technology
    Replies: 1
    Last Post: 04-18-2001, 02:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts