Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2008
    Location
    Uruguay
    Posts
    85

    problem with .mp4 videos.

    Hello everybody,



    I have a problem with some mp4 videos and the downloads made from cellphones.



    I have a plain LAMP server (centos 5, apache 2, php 5), the customers download the videos from a web, mobile section, and play on their cellphones.



    The strange thing is that when they opened the video to play it on the cellphone, the video shows itself as a binary, although the extension remains mp4.



    Tried moving the same video to another server, and it was played ok without any changes.. so, tested another server and after making this changes, it was able to reproduce the mp4 format:



    I changed the Default mime.types from text/plain to application/octet-stream



    TypesConfig / etc / mime.types



    # DefaultType is the default MIME type the server will use for a document

    # If it can not otherwise determine one, such as from filename extensions.

    # If your server contains mostly text or HTML documents, "text / plain" isnte

    # A good value. If most of your content is binary, such as applications

    # Or images, you may want to use "application / octet-stream" instead to

    # Keep browsers from trying to display binary files as though they are

    # Text.

    #

    DefaultType application / octet-stream



    When the videos out in binary, with a lot of strange characters, leaving just this: application / octet-stream



    I see in /etc/mime.types and there is support for many formats, including. Mp4



    However, on the original first server even if I change the above code, I can not reproduce mp4.



    On any laptop or pc from the three servers I can reproduce the videos, the problem it’s just on one server playing from cellphones.



    I think it's a parsing problem.



    Do you have any suggestions for me on this?



    What do you think?



    Regars,

    Marcelo Ramone.-

  2. #2
    Join Date
    Apr 2008
    Location
    Uruguay
    Posts
    85
    I enabled registers_globals in php.ini and the problem was solved.

    Thanks.-

  3. #3
    Join Date
    Nov 2007
    Location
    India
    Posts
    843
    Quote Originally Posted by Marcelo Ramone View Post
    I enabled registers_globals in php.ini and the problem was solved.

    Thanks.-
    great to hear that you resloved the issue by yourself
    HostNotch Hosting Services 99.9% uptime Shared Hosting, Reseller Hosting
    yajur | Sales Team
    CPanel Hosting R1 Soft Offsite-Backup Great Uptime
    http://hostnotch.com sales @ hostnotch.com

Similar Threads

  1. Developed Bodybuilding Videos Site & Cartoon Videos Site For Sale
    By F15.Com in forum Domain Name with Web Site Offers
    Replies: 0
    Last Post: 04-14-2009, 04:01 PM
  2. I need Videos!
    By KGO in forum Other Offers & Requests
    Replies: 0
    Last Post: 10-19-2007, 11:13 PM
  3. Videos I was looking at...
    By Webdude in forum Web Hosting Lounge
    Replies: 4
    Last Post: 06-19-2005, 02:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •