Results 1 to 13 of 13
  1. #1

    Question Problem getting GUI on new centOS VPS?

    Hi;
    I'm still a complete noob with linux and after several days testing different distributions and a bunch of different ways (e.g. freenx,vnc XFCE ...) I've decided to setup a vnc-server on CentOS-5-i386-minimal and use KDE as a desktop environment.

    After reloading my vps with centos-5-i386-minimal, I logged in as root and executed:

    Code:
    yum update
    yum -y groupinstall "KDE (K Desktop Environment)"
    yum -y install vnc vnc-server firefox X11 xorg
    I then added a user "abt" and set the password. Then I logged in as abt and execute : vncserver, it asked for the password and created the appropriate .vnc directory and files.
    I then edited xstartup file and replaced "twm &" with "startkde &" and executed vncserver once again, this created desktop number 2 for me.

    The problem is that after running TightVNC(on vista) and entering IPNUMBER:2, It successfully connects to vnc-server but what i get is a black screen with X cursor!

    I really have no idea what's the reason, can someone help me plz ?

  2. #2
    Join Date
    Mar 2003
    Location
    New York City
    Posts
    7,391
    Hi

    Have you contacted your VPS host about this? This may be something on their end causing it.
    CirtexHosting Providing Affordable and Quality Web Hosting & Reseller Hosting since 2003
    LINUX based cPANEL/WHM Shared and Reseller Web Hosting with Fantastico
    HostV VPS Premium Virtual Private Servers & Dedicated Servers powered by cPanel/WHM
    We transfer your sites over quickly! I eat penguins for breakfast ...

  3. #3
    They have told me there is no reason why I can't install this and get it works.

  4. #4
    Join Date
    May 2006
    Location
    NJ, USA
    Posts
    6,456
    there is a yum group package, X Window System, or something similar, install that as well

  5. #5
    Quote Originally Posted by Dougy View Post
    there is a yum group package, X Window System, or something similar, install that as well
    Do I need to configure anything or just install that pckg?
    Btw I've installed GNOME this time however the problem still persists!

  6. #6
    Join Date
    May 2009
    Location
    US
    Posts
    2,502
    Try: chmod +x .vnc/xstartup

    then kill all vncserver processes, try connecting again.

  7. #7
    Join Date
    Jun 2006
    Location
    United Kingdom
    Posts
    1,766
    What does the log in .vnc contain?
    -- Adam

  8. #8
    I've tried that chmod trick but it didn't work Thanks anyway.

    As user 'abt' the log file is:


    Code:
    Sun Oct 18 21:30:38 2009
     vncext:      VNC extension running!
     vncext:      Listening for VNC connections on port 5901
     vncext:      Listening for HTTP connections on port 5801
     vncext:      created VNC server for screen 0
    sh: /home/abt/.vnc/xstartup: /bin/sh^M: bad interpreter: No such file or directory
    
    Sun Oct 18 21:31:01 2009
     Connections: accepted: XX.XXX.XXX.XXX::62821
     SConnection: Client needs protocol version 3.8
     SConnection: Client requests security type VncAuth(2)
    
    Sun Oct 18 21:31:09 2009
     VNCSConnST:  Server default pixel format depth 16 (16bpp) little-endian rgb565
     VNCSConnST:  Client pixel format depth 8 (8bpp) bgr233
    
    Sun Oct 18 21:31:15 2009
     Connections: closed: XX.XXX.XXX.XXX::62821 (Clean disconnection)
     SMsgWriter:  framebuffer updates 2
     SMsgWriter:    hextile rects 3, bytes 3234
     SMsgWriter:    raw bytes equivalent 786980, compression ratio 243.345702
    I myself closed TightVNC at the end.

  9. #9
    Join Date
    Jul 2007
    Posts
    205
    You didn't install x windows
    Code:
    yum groupinstall "X Window System"
    And then, change the following line on /etc/inittab
    Code:
    id:3:initdefault:
    With
    Code:
    id:5:initdefault:

  10. #10
    Thanks Arsenico
    I've already installed that "X Window System". I changed /etc/inittab but that doesn't work either. This problem is getting me mad while everyone do that easily, I've been playing with the server for 5 days and still nothing is happend.

  11. #11

    Thumbs up

    Hey Arsenico it works, I rebooted the system and after executing "vncserver" this time when I run TightVNC and connected to my vps I got a command line there and I executed startkde and WOW can't belive that it finally works.
    Thanks man you don't know how thankful I am. You're great!
    Last edited by armin64; 10-18-2009 at 06:30 PM.

  12. #12
    Join Date
    Jul 2007
    Posts
    205
    I did the same yesterday.-
    Since i'm testing somethings to be ready on january, i installed KDE on a centos server That's why i could remember the steps.-

    Anyway, you'r welcome, let me know if you need something else!


    BTW: I forgot to tell you "reboot" my mistake, sorry.

  13. #13
    Join Date
    Aug 2004
    Location
    Shanghai
    Posts
    1,449
    Hi,

    Using VNC to connect to X is quite an old thing. DO NOT use VNC, and setup NX instead, it's a way faster, and a lot more easy to use!!!

    Thomas
    GPLHost:>_ open source hosting worldwide (I'm founder, CEO & official Debian Developer)
    Servers & our leading control panel and our Xen VPS hosting, which are already included in Debian and Ubuntu
    Available in: Kuala Lumpur, Singapore, Sydney, Seattle, Atlanta, Paris, London, Barcelona, Zurich, Israel

Similar Threads

  1. Problem with vnc on centOS 5. Help me :')
    By M0H4N in forum Hosting Security and Technology
    Replies: 0
    Last Post: 12-01-2007, 06:54 AM
  2. Problem with installing HyperVM on CentOS (Problem w/ YUM?)
    By DennisM in forum Hosting Security and Technology
    Replies: 4
    Last Post: 11-05-2007, 09:05 PM
  3. Problem with CentOs 5.0
    By VIETHOSTING in forum Hosting Security and Technology
    Replies: 2
    Last Post: 10-05-2007, 09:11 AM
  4. centos problem
    By darkink in forum Hosting Security and Technology
    Replies: 8
    Last Post: 05-16-2006, 05:49 PM
  5. Another CentOS problem
    By raqman in forum Hosting Security and Technology
    Replies: 1
    Last Post: 03-21-2005, 05:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •