First problem i have is i am getting 403 forbidden error for cgi-bin/

I have created a new /var/www2/ i can access it fine. php runs fine.

Second problem is I cannot password protect it. i first tried doing htpasswd, it asks for login but everytime i login it keeps asking for new one.

its getting frustrating, i have tried all tricks. and doesn't seem to work.

this is a virtual host config inside sites-available. httpd.conf is empty but i have apache2.conf

        ServerAdmin [email protected]

        DocumentRoot /var/www2/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        <Directory /var/www2/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all

        ScriptAlias /cgi-bin/ /var/www2/cgi-bin/
        <Directory "/var/www2/cgi-bin/">
                AllowOverride Options
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                AddHandler cgi-script cgi pl
                Order allow,deny
                Allow from all

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from ::1/128