Results 1 to 5 of 5
  1. #1

    How to install CURL?

    I tried several methods to activate curl, but nothing until now.

    libcurl is in extension_dir, extension is loaded in php.ini, but something is still going wrong.

    I tried to install with yum, from source, from rpm. nothing.

    this it my error
    Code:
    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir...
    from phpinfo():

    Code:
    safe_mode	Off
    safe_mode_exec_dir	no value
    safe_mode_gid	Off
    safe_mode_include_dir	no value
    Now I saw an error. in php.ini open_basedir = Off , but in phpinfo() I get this

    open_basedir /home/admin/:/tmp:/usr/local/lib/php/

    no ideas

  2. #2
    Try setting the open_basedir to none

    In httpd.conf, in the virtual host entry of the domain add the below line
    php_admin_value open_basedir none

    OR

    Below line to php.ini file(but i don't think this will work as the virtualhost entry in apache configuration will override this default value)
    open_basedir = none

  3. #3
    Join Date
    May 2009
    Location
    NL
    Posts
    35
    if you have cpanel the best way is:
    to go to whm --> then on your home click software --> click easyapache --> were it says "Begin by selecting a profile to load:" click basic --> then click start customizing based on profile --> select apache 2.0 and click next step --> Check which php version you want to use (pref php 5) and click next step --> click 5.2.8 and then next step --> now you should be on the Short Options List. While you are here i would advise turning zend and ioncube on and click EXHAUSTIVE OPTIONS LIST --> now that your on the Exhaustive Options List scroll down to php 5.2.8 and check mark curl. --> now scroll all the way down to the bottom and click save and build. now let whm build php and apache!. Grab a coffee you deserve it!

  4. #4
    Join Date
    Apr 2009
    Location
    India
    Posts
    8
    Php compilation through WHM interface can cause issues. It would be better to login to the shell as root and execute the following command there

    /scripts/easyapache

    You can select the needed options as stated above there.

  5. #5
    Sorry guys, I work wil directadmin(personal reason).

    Thanks for help, problem has been fixed. I just commented that line containing CURLOPT_FOLLOWLOCATION , and seems like script is working well. That line was just to allow redirections.

    And I have installed on vps standlone packages: php , apache, mysql, not compelte like easyapache or lamp

Similar Threads

  1. [REQ] Install cURL?
    By viva4google in forum VPS Tutorials
    Replies: 3
    Last Post: 07-08-2007, 02:20 AM
  2. Install cUrl
    By WebNerdz in forum Hosting Security and Technology
    Replies: 15
    Last Post: 02-11-2007, 04:39 AM
  3. curl install
    By JustaJoe in forum Hosting Security and Technology
    Replies: 5
    Last Post: 01-18-2005, 10:07 PM
  4. how to install CURL
    By dico in forum Dedicated Server
    Replies: 2
    Last Post: 06-11-2003, 11:18 AM
  5. Pay Someone to Install CURL
    By tymonhall in forum Dedicated Server
    Replies: 11
    Last Post: 10-24-2001, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •