Results 1 to 15 of 15
  1. #1
    Join Date
    Aug 2009
    Location
    Philippines
    Posts
    18

    Memory Limit in VPS [URGENT]

    All Wordpress on our VPS is currently experiencing this problem:

    Fatal error: Out of memory (allocated 18874368) (tried to allocate 122880 bytes)

    I don't know how to fix it. HELP!

  2. #2
    Join Date
    Jun 2008
    Location
    UK
    Posts
    265
    well, i dont think you can fix it - sounds like your VPS is out of memory and you need to upgrade it.
    WebCertain - SEO, PPC, PR - The services you need to increase your site traffic. Specialists in over 35 languages and country-specific SEO! www.webcertain.com

  3. #3
    Join Date
    Aug 2009
    Location
    Philippines
    Posts
    18
    But it's already upgraded. Still the same issue.

  4. #4
    Join Date
    Feb 2004
    Location
    USA
    Posts
    1,571
    Seems like your VPS is out of memory,

    Who's your provider? maybe they are overselling?

    Cheers

  5. #5
    Join Date
    Mar 2009
    Posts
    2,218
    Quote Originally Posted by webcertain View Post
    well, i dont think you can fix it - sounds like your VPS is out of memory and you need to upgrade it.
    It sounds more like a software configuration problem to me, possibly a memory limit in PHP - which you can change (either in php.ini or in .htaccess)

    Anyway, the first step is to go through the Wordpress installation instructions, making sure everything is as it should be.

    After that, go to the Wordpress support forums. Almost certainly someone will have had the problem before.

  6. #6
    Join Date
    Aug 2009
    Location
    Philippines
    Posts
    18
    Yes, it's the memory limit for PHP.
    I tried and they say that I have to adjust it. But I've been adjusting it.. and.. Well, no effect.

  7. #7
    Join Date
    Feb 2006
    Location
    North West England
    Posts
    612
    Have you tried restart httpd to reload php.ini?
    Regards,
    Leigh

    Host High - reliable UK hosting

  8. #8
    Quote Originally Posted by Kisty View Post
    All Wordpress on our VPS is currently experiencing this problem:

    Fatal error: Out of memory (allocated 18874368) (tried to allocate 122880 bytes)

    I don't know how to fix it. HELP!
    Hi!

    Sorry for answering with another question, could you please elaborate on your current configuration?:

    + Kind of VPS (OpenVZ/Virtuozzo, Xen, Linux VServers, KVM, VMWare, VirtualBox....).
    + Size of VPS (RAM, specially RAM), but depending on the VPS kind (previous item), there could be other parameters to look after, this is specially true for OpenVZ.
    + Your current flavor/config of web server.

    When you have the info, just post it, please, remember to remove any info you don't want public, maybe: domain name, email addresses, IP addresses, .....

    I hope to help,

    Ildefonso Camargo

  9. #9
    Join Date
    Jul 2009
    Location
    USA,NC
    Posts
    115

  10. #10
    Join Date
    Nov 2002
    Location
    WebHostingTalk
    Posts
    8,878
    * Moved to Technical and Security Issues....

    Sirius
    I support the Human Rights Campaign!
    Moving to the Tampa, Florida area? Check out life in the suburbs in Trinity, Florida.

  11. #11
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    You may contact your provider and ask him to increase the parameter KMEMSIZE for your vps.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  12. #12
    Join Date
    Feb 2004
    Location
    USA
    Posts
    1,571
    Quote Originally Posted by CaroNetTanya View Post
    Check the php.ini on your VPS and increase the necessary limit "memory_limit" for example to 32 or 64 mb:
    memory_limit = 32M
    or
    memory_limit - 64M

    Hope this help..
    You can also try the options 128M try it and see if it help,

    Remember to restart httpd

    # service httpd restart

  13. #13
    Join Date
    Mar 2009
    Posts
    2,218
    Quote Originally Posted by Kisty View Post
    Yes, it's the memory limit for PHP.
    I tried and they say that I have to adjust it. But I've been adjusting it.. and.. Well, no effect.
    OK, so what *exactly* did you do?

  14. #14
    Hi, again,

    Yes, almost everyone know that's a php message, but if you want to prevent further problems, you need to tune the parameters according to the server you have, for example, you could add:

    memory_limit = 256M (for example)

    and have apache with mpm prefork, and have a max of 150 childrens, then you could en up requiring up to: yay, 37.5GB! RAM (physical + swap), off course, this is hypothetical, because this is the worst of the cases where the app can actually eat 256M for each request, which is not always true.

    Also, you have to fine-tune the DB, so it doesn't eat lots of memory, but all of this parameters will depend on:

    + Size of VPS,
    + Kind of VPS: whether the VPS have or have not swap, depending on the kind of VPS, there can be other parameters to take into account.

    I hope this helps,

    Ildefonso Camargo

  15. #15
    Join Date
    Apr 2009
    Location
    inside wht
    Posts
    716
    If it is openvz vps , what is your vmguarpage and kmemzise values ?

Similar Threads

  1. How to limit the CPU & memory usage?
    By KennyP in forum Dedicated Server
    Replies: 4
    Last Post: 01-09-2008, 02:08 PM
  2. vps memory limit (virtuozzo)
    By killerstorm in forum VPS Hosting
    Replies: 3
    Last Post: 03-29-2007, 01:26 PM
  3. PHP memory limit?
    By blackdog in forum Web Hosting
    Replies: 10
    Last Post: 07-16-2004, 04:06 PM
  4. RaQ Memory Limit
    By benwell in forum Dedicated Server
    Replies: 5
    Last Post: 04-08-2004, 01:45 AM
  5. PHP memory limit
    By daveman in forum Hosting Security and Technology
    Replies: 1
    Last Post: 01-03-2003, 07:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •