Results 1 to 13 of 13
  1. #1

    Unhappy UNetbootin -- CentOS install *from* USB stick

    Hello All:

    We are looking for ways to INSTALL CentOS 4.7 and 5.3 (to servers) *from* a USB stick (instead of a CD or DVD).

    There seem to be several people who created scripts and HOW-TOs to do this. But the simplest way seems, from what I could find, a program called "UNetbootin" that can be downloaded at sourceforge.net:
    http://unetbootin.sourceforge.net/
    Also see the Wikipedia entry: http://en.wikipedia.org/wiki/UNetbootin

    Now, I used this under Windows XP. Dowloaded e.g. the "ServerCD" ISO for CentOS 4.7 (http://mirrors.serveraxis.net/centos/4.7/isos/i386/) -- "CentOS-4.7.ServerCD-i386.iso," and then used the "UNetbootin" script to create a USB stick install that would match the CentOS on CD. So far it all worked fine.

    P r o b l e m :
    When I now insert this in a new server, the server does not recognize that USB stick with CentOS 4.7 (same for 5.3 USB stick). In the server's bios USB is set to be read FIRST.

    Has anyone any experience using "UNetbootin" for such purpose. Did I even completely misunderstand what "UNetbootin" is going to do? (In that case, other alternatives?)

    Best,
    John
    Last edited by Johnn; 10-05-2009 at 12:56 AM.

  2. #2
    Join Date
    Jun 2004
    Location
    Oregon
    Posts
    1,282
    use liveusb-creator https://fedorahosted.org/liveusb-creator/
    it works with centos.

  3. #3
    Join Date
    Mar 2005
    Location
    New York City
    Posts
    2,559
    If you're installing on fresh servers, I'm assuming you already have a network in place?

    Have you attempted to use PXE with an autoloader so the server will boot the image off of the network and remotely load the data for installation?

    No human interaction would be necessary, which makes this method more awesome.
    Matthew Rosenblatt, and I do lots of things.
    Currently a Master Electrician on Broadway.
    My company, BurstAV, specializes in A/V Systems Design and integration.
    I also own ConcertCables. We build power/data cables for the entertainment industry.

  4. #4
    Hello meyu, hello Matt:

    Thank you both!

    These are two different topics -- but yes, Matt, thanks, I also had another post on this board asking for ways to install a Linux OS remotely.

    meyu, I tried that install also -- works the same way, as far as I can say, then the script I mentioned. I am getting the exact same error though: "no bootable device". Just to be sure, when you create such USB stick with a Linux distribution, I should be able to stick this into a brand new server and boot it .... not just use it on a PC that has e.g. Windows installed already, yes?

    Matt, thanks again. I found this Wikipedia site about PXE:
    http://en.wikipedia.org/wiki/Preboot...on_Environment
    On the practical end -- we are VERY interested in implementing this for our racks -- can you suggest any website with instructions, possibly any script that helps setting up such remote reboot installer server? Thanks.

    John

  5. #5
    Join Date
    Jun 2004
    Location
    Oregon
    Posts
    1,282
    hmm, weird. i've been using that method loading fresh centos 5 for some servers without any issue. it's possible due to the problem of your usb stick though, heard some usb sticks just can't boot.

  6. #6
    Thanks again.

    First, the server I try this with is not connected to the network (right now), trying this at home actually. But that should not be an issue, I think, at least the installer should load.

    BIOS settings are:
    - USB boot -- enabled
    - USB boot First -- enabled

    I am getting this:
    ---------
    Boot error
    (...)
    PXE-E61 - Media test failure, check cable
    (...)
    No bootable device ...
    ---------

    But the USB ports work fine, otherwise the keyboard would not work either.

    Regarding USB stick (hardware) -- I tried with a new 8 GB stick
    ("ativa") and another "DataTraverler 120" -- and I re-formatted them under Windows. Must be something else then. But thanks for letting me know ... I should try this on another server type later.

    Post Scriptum: Is there any need for the USB stick to be named in a certain way?


    John
    Last edited by Johnn; 10-05-2009 at 04:17 PM.

  7. #7
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    5,842
    I'd suggest you try with a smaller USB stick (1 or 2GB). My unetbootin USBs (which do work) are formatted vfat / FAT32.
    Chris

    "Some problems are so complex that you have to be highly intelligent and well informed just to be undecided about them." - Laurence J. Peter

  8. #8
    S o l u t i o n :

    Well, there are variations on how the bios menu looks on different server types. On this one, in the "BOOT" section, I had this entry:

    USB Mass Storage Emulation Type

    And it was set to "Auto." After I changed this setting to "All Fixed Disc" I was able to boot from the USB stick and the CentOS installer starts. Great!

    Thanks everyone.


    John

  9. #9
    Didn't think I'd be back here so fast:
    Next small problem: During installation (I am testing this with the CentOS 4.7 server disk), I get to the screen where it is asked what "Installation Method" to use:
    - Local CDROM
    - Hard drive
    - NFS image
    - FTP
    - HTTP

    What do I do from here?

    With a CD-ROM install I would choose "Local CDROM" and then pick the "USB Mass Storage" driver in the upcoming list ... but, this is not a CD-ROM now, and second, the "USB Mass Storage" driver is NOT listed. Should I still opt for "Local CDROM" and then for "Use driver disk" and go to the USB stick ("sdc" drive")? If so, is there any driver ... will I not need it?
    On the other hand, if I opt for "Hard drive" and then for "/dev/sdc1" (= USB stick) I get an error saying that this partition does not seem to have any CD-ROM image.


    John

  10. #10
    Join Date
    Jun 2004
    Location
    Oregon
    Posts
    1,282
    should choose hard drive and then sdx, and you also need to put the whole iso image in the usb stick.

  11. #11
    The USB stick appears as "sdc" (not sdx) ... the server has 2 hard drives, and with the settings in the bios (see my note above) the USB stick imitates a 3rd one -- that at least is my understanding. The menu does not opt for "sdx" -- should it, or was it a typo?

    The "UNetbootin" script copies the content of the CentOS install ISO onto the USB stick ... you probably do not mean that there should be an .ISO image on the USB stick as well, yes?

    John

  12. #12
    Join Date
    Jun 2004
    Location
    Oregon
    Posts
    1,282
    what i mean by sdx is like sda1, sdb1, sdc1...not sure which one is your usb stick.
    other than the content "UNetbootin" copied you still need that original iso file in it.
    there maybe other ways to do this but this is the only working method i found.

  13. #13
    Thanks meyu.
    Turned out it was one of these silly little details ... as usual:
    While running the CentOS installer (on the server, from the USB drive), after choosing "Hard drive" as place to install from, I did actually type "/dev/sdc1" -- and that did not work. But when I left that empty and just hit ENTER it does work and the installer continues. (NOTE that "/dev/sdc1" was already showing as pre-selected option in another window atop of the writable [but empty] entry field.)

    I should note that a copy of the .ISO file is not necessary (same as on the installer CD, which has all the RPMs). Again, I used "UNetbootin" to create the USB installer, and you likely used "liveusb-creator" ... which looks quite the same, but maybe there is a difference then.

    Thanks again.

    John

Similar Threads

  1. Replies: 2
    Last Post: 06-12-2009, 11:31 PM
  2. Install Vpn on Centos
    By robocap in forum Employment / Job Offers
    Replies: 4
    Last Post: 07-23-2007, 12:13 PM
  3. centos:apache,php, yum install or source install?
    By cchere in forum Hosting Security and Technology
    Replies: 2
    Last Post: 08-29-2006, 05:14 PM
  4. Install CentOS, ...
    By MarsNIIT in forum Hosting Security and Technology
    Replies: 8
    Last Post: 03-31-2006, 10:50 PM
  5. How do I install GD on a default CentOS 4.x install?
    By Fabalo.com in forum Hosting Security and Technology
    Replies: 3
    Last Post: 02-12-2006, 11:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •