Results 1 to 7 of 7
  1. #1
    Join Date
    Aug 2009
    Location
    Ann Arbor, MI, USA
    Posts
    40

    SSL installation issues?

    I purchased Rapid SSL from name cheap.com and tried to install it on my server with the hope of being able to use it with Prestashop an ecommerce software. But, when I finished installing I get

    SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long)

  2. #2
    Did you restart httpd?

    Make sure you have checked the obvious, like is the IP address marked as dedicated (or similar) in your cp. Did you assign the right user to the right IP address etc.

    What httpd deamon are you running, what control panel??
    Ore Stone Radio
    Playing the best unsigned new music 24 hours a day
    Musicians - Visit our forums to submit your music for airplay

    www.orestoneradio.com an Ore Stone Music Ltd. Company

  3. #3
    Join Date
    Feb 2004
    Location
    USA
    Posts
    1,571
    Hello nos879,

    Are you still having this problem?

    Most of the time this error comes from mixup of the ca-bundle with the crt, did you install in the correct order?

    Cheers.

  4. #4
    Join Date
    May 2009
    Location
    SLASH ROOT
    Posts
    853
    Check the Apache logs for the exact error. If you can't figure out the cause, check the following:

    1) Make sure port 443 is open and http over SSL is listening in that port.

    netstat -plan | grep :443

    2) Make sure that the SSL VirtualHost section for the domain is set up correctly.

    <VirtualHost domain.tld:443>
    ....
    .....
    </VirtualHost>

  5. #5
    Join Date
    Aug 2009
    Location
    Ann Arbor, MI, USA
    Posts
    40
    Quote Originally Posted by Ore Stone Radio View Post
    Did you restart httpd?

    Make sure you have checked the obvious, like is the IP address marked as dedicated (or similar) in your cp. Did you assign the right user to the right IP address etc.

    What httpd deamon are you running, what control panel??

    I am using cPanel on a Linux Server with itsjusthosting.com


    Quote Originally Posted by TheServerExperts View Post
    Hello nos879,

    Are you still having this problem?

    Most of the time this error comes from mixup of the ca-bundle with the crt, did you install in the correct order?

    Cheers.
    I hope I did install it in the correct order, I got the csr, and then they gave me my certificate

    Quote Originally Posted by whrss View Post
    Check the Apache logs for the exact error. If you can't figure out the cause, check the following:

    1) Make sure port 443 is open and http over SSL is listening in that port.

    netstat -plan | grep :443

    2) Make sure that the SSL VirtualHost section for the domain is set up correctly.

    <VirtualHost domain.tld:443>
    ....
    .....
    </VirtualHost>
    Whrss I do remember people talking about the 443 and even mentioning restarting the server. But all the stuff you mentioned I have no idea how to do. All I see is an SSL manager. I haven't yet figured out how to check where port 443 is. (I'm new to webhosting).

  6. #6
    Join Date
    Aug 2007
    Posts
    30
    Hi,

    This error usually comes due to invalid or missing Virtual Host entry for 443 (SSL). Ask your hosting provider to check with this. If its your dedicated server then you need to check with a good system administrator who can check your apache config file.

  7. #7
    Join Date
    May 2009
    Location
    SLASH ROOT
    Posts
    853

Similar Threads

  1. Artic Issue Tracker installation Issues
    By maxriskfactor in forum Hosting Software and Control Panels
    Replies: 0
    Last Post: 05-18-2009, 08:32 AM
  2. TorrentFlux Installation issues, while checking system tools
    By semplix in forum Hosting Security and Technology
    Replies: 3
    Last Post: 09-20-2008, 09:00 PM
  3. LAMP installation + Video modules installation | FFMPEG MPLAYER PHP MYSQL
    By dev_stefan in forum Employment / Job Requests
    Replies: 5
    Last Post: 04-18-2008, 03:08 PM
  4. Quagga - running into installation issues
    By DataCentric in forum Colocation and Data Centers
    Replies: 5
    Last Post: 10-25-2006, 12:41 PM
  5. software installation issues on goDaddy VD (VPS?)
    By frodiggs in forum VPS Hosting
    Replies: 1
    Last Post: 01-09-2006, 12:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •