Results 1 to 10 of 10
  1. #1
    Join Date
    Sep 2008
    Location
    Dallas, TX
    Posts
    4,552

    Ubersmith friendly hosts?

    Howdy WHT, I was wondering if any of y'all know Ubersmith friendly hosts. If you do, post 'em please.


    Thanks,
    Jacob
    Jacob Wall - GetCloak.com

  2. #2
    http://www.ubersmith.com/clients/

    Otherwise, you could contact them directly and I'm sure they'd be glad to recommend you some options.
    Sean Shepard
    http://www.Ethoshosting.com - Socially Responsible Web Hosting

  3. #3
    Join Date
    Jul 2005
    Location
    In the Internets
    Posts
    3,622
    ^^^

    Those are just companies that run ubersmith. I assume ubersmith only needs PHP + MySQL, any shared host should be able to do this for you.
    StableHost .:. Unlimited web hosting done right. Experience the unlimited difference.
    PingThat .:. Is your website down? Find out now with our QuickChecker technology.

  4. #4
    Join Date
    Sep 2008
    Location
    Dallas, TX
    Posts
    4,552
    Quote Originally Posted by nerdie View Post
    ^^^

    Those are just companies that run ubersmith. I assume ubersmith only needs PHP + MySQL, any shared host should be able to do this for you.
    That's what I would think, guess it needs a lot more



    Ubersmith requires the Gettext PHP extension in order to run.
    The program execution functions shell_exec(), passthru() and exec() are disabled by the disable_functions parameter in php.ini. This can only be set server-wide, so you will need to change it in the global php.ini.

    *and*

    Code:
    ; Ubersmith PHP Configuration
    ;
    ; When running under CGI, this file will need to be installed in your
    ; web root.  Use the following commands to perform the installation.
    ;
    ; cd ..
    ; cp setup/php.ini-dist php.ini
    ; find . -type d -mindepth 1 -exec sh -c 'ln -s "$(echo "$1" | sed "s/^\.\///" | sed "s/[^\/]\+/../g")/php.ini" "$1"/' . {} \;
    ;
    ; If you still see the php.ini error, please contact support.
    
    safe_mode = off
    
    include_path = ".:include:../include:../../include:../../../include"
    default_charset = "UTF-8"
    memory_limit = 64M
    
    register_argc_argv = on
    register_globals = off
    session.auto_start = off
    
    highlight.bg = "#000000"
    
    upload_max_filesize = 16M
    post_max_size = 50M
    max_execution_time = 60
    max_input_time = 600
    
    magic_quotes_gpc = off
    magic_quotes_runtime = off
    magic_quotes_sybase = off
    
    mbstring.language = Neutral
    mbstring.internal_encoding = UTF-8
    mbstring.http_input = pass
    mbstring.http_output = pass
    mbstring.encoding_translation = off
    
    ; Useful on hosts running cPanel with PHP as a CGI
    ;[Zend]
    ;zend_extension=/usr/local/Zend/ioncube/ioncube_loader_lin_5.2.so
    ;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.8
    ;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.8
    ;zend_optimizer.version=3.2.8
    ;zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    ;zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
    Jacob Wall - GetCloak.com

  5. #5
    Unfortunately your right ubersmith does need those things.

    Really you should look at running it on it's own server. You should be hosting your site & emails (and everything else) seperately anyway.

    If your not sure about the requirements or looking after a server, then go for a dedicated server.

    Otherwise you can see if you can find a shared host that will let you run it or go for a different billing system.

    Ubersmith is aimed at the "larger" companies compared to whmcs/clientexec etc.
    Data Republic - UK Managed Servers - Server Management - Managed Backup/R1Soft
    Follow us on Twitter to get exclusive sales & updates.
    R1Soft Agents Monthly !

  6. #6
    Quote Originally Posted by Jacob Wall View Post
    That's what I would think, guess it needs a lot more



    Ubersmith requires the Gettext PHP extension in order to run.
    The program execution functions shell_exec(), passthru() and exec() are disabled by the disable_functions parameter in php.ini. This can only be set server-wide, so you will need to change it in the global php.ini.

    *and*

    Code:
    ; Ubersmith PHP Configuration
    ;
    ; When running under CGI, this file will need to be installed in your
    ; web root.  Use the following commands to perform the installation.
    ;
    ; cd ..
    ; cp setup/php.ini-dist php.ini
    ; find . -type d -mindepth 1 -exec sh -c 'ln -s "$(echo "$1" | sed "s/^\.\///" | sed "s/[^\/]\+/../g")/php.ini" "$1"/' . {} \;
    ;
    ; If you still see the php.ini error, please contact support.
    
    safe_mode = off
    
    include_path = ".:include:../include:../../include:../../../include"
    default_charset = "UTF-8"
    memory_limit = 64M
    
    register_argc_argv = on
    register_globals = off
    session.auto_start = off
    
    highlight.bg = "#000000"
    
    upload_max_filesize = 16M
    post_max_size = 50M
    max_execution_time = 60
    max_input_time = 600
    
    magic_quotes_gpc = off
    magic_quotes_runtime = off
    magic_quotes_sybase = off
    
    mbstring.language = Neutral
    mbstring.internal_encoding = UTF-8
    mbstring.http_input = pass
    mbstring.http_output = pass
    mbstring.encoding_translation = off
    
    ; Useful on hosts running cPanel with PHP as a CGI
    ;[Zend]
    ;zend_extension=/usr/local/Zend/ioncube/ioncube_loader_lin_5.2.so
    ;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.8
    ;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.8
    ;zend_optimizer.version=3.2.8
    ;zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    ;zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
    more then that

    if you are using Ubersmith for graphing, etc - it is quite intensive. You really should not run this on a shared server (unlikely you would be able to anyway). At a minimum, if you are just starting out, get a good VPS, with guaranteed resources (CPU and RAM) - and go from there.. You can then scale as needed. We are currently implementing Ubersmith and tried on a VPS, before finally slapping ourselves around and moved it to 2 pretty beefy servers.

  7. #7
    Join Date
    Oct 2006
    Location
    Pittsburgh, PA
    Posts
    242
    What version were you specifically looking at running? I've tried the LITE version on a VPS about $10/month, worked great while I had it.
    Jon Stephenson

  8. #8
    Join Date
    Sep 2008
    Location
    Dallas, TX
    Posts
    4,552
    Quote Originally Posted by CompuSite View Post
    What version were you specifically looking at running? I've tried the LITE version on a VPS about $10/month, worked great while I had it.
    Lite. Thanks for that info
    Jacob Wall - GetCloak.com

  9. #9
    Quote Originally Posted by Jacob Wall View Post
    Lite. Thanks for that info
    the lite version is better as far as resource requirements go.. but, do yourself a favour - do not run anything on a $10 VPS - especially not something considered to be mission critical like Ubersmith - nothing good can come of that

  10. #10
    Join Date
    Oct 2006
    Location
    Pittsburgh, PA
    Posts
    242
    Quote Originally Posted by cartika-andrew View Post
    the lite version is better as far as resource requirements go.. but, do yourself a favour - do not run anything on a $10 VPS - especially not something considered to be mission critical like Ubersmith - nothing good can come of that
    Agreed. Only do it if it's for a short period of time.
    Jon Stephenson

Similar Threads

  1. Mailing List Friendly Hosts
    By bkushner in forum Web Hosting
    Replies: 3
    Last Post: 10-19-2008, 04:37 AM
  2. Ubersmith Inc. Announces Ubersmith Datacenter Edition For Service Providers
    By ubersmith in forum Web Hosting Industry Announcements
    Replies: 0
    Last Post: 10-04-2006, 03:36 PM
  3. Mac-friendly reseller hosts?
    By AppleCider in forum Reseller Hosting
    Replies: 13
    Last Post: 11-01-2000, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •