Results 1 to 12 of 12
  1. #1

    Video doesn't show up right in Firefox

    ok, i have this video on this page, when i view this video on Internet Explorer, it looks fine, but when I view this link on Firefox, the video looks different, it only shows the corner of the video.

    backwardsentertainment.com/custom/freeservices.html

    I embedded the video into the webpage for the video to show up. The embedded code that i used is

    <embed src="video/WelcomeHome.wmv" autostart="true" width="320" height="240"></embed>

    can someone help me to get this video to look the same in Firefox as it does in Internet Explorer?
    Any help would be appreciated.
    Thanks,

  2. #2
    Join Date
    Aug 2002
    Location
    United Kingdom
    Posts
    290
    Firefox users need an addon to display WMV files inline on websites.
    DesignBear.com
    View Portfolio

    A trusted WHT member for over 7 years!

  3. #3
    what addon do i need to display WMV files?

  4. #4
    Join Date
    Aug 2002
    Location
    United Kingdom
    Posts
    290
    I provided a link above Mike. Click on the text 'addon' in my previous post - it's underlined.

    I would however strongly recommend that you start converting your media to flv format if you're going to stream it. This way you can incorporate it into posts much easier and can customise the player that it displays to match your website.

    You can find a great free suite to do all of this by clicking on this link

    If you don't require all of this software, you can find the video converter tool here.

    I've used it for many of the websites I run, an example of which can be seen here (scroll down and click on the play icon to view the video quality etc).

    Hopefully this helps, good luck.
    DesignBear.com
    View Portfolio

    A trusted WHT member for over 7 years!

  5. #5
    ther's a plugin to play such kind of video i think its windows media player plugin for firefox intall it and see

  6. #6
    the video converter program worked great! thanks very much!
    i did notice though, that on Internet Explorer, there is are buttons that contain play, stop, volume.
    Those buttons do not show up on Firefox, there is only play on Firefox. Is there a way to have those buttons show up in Firefox?
    Thanks for all your help!
    I appreciate it!

  7. #7
    Join Date
    Aug 2002
    Location
    United Kingdom
    Posts
    290
    Hey,

    I've tested the video box in IE6, IE7 and FF and it seems to be showing the buttons and playing the video just fine.

    Do you want to perhaps take a screenshot and show the problem you're having? Cheers.
    DesignBear.com
    View Portfolio

    A trusted WHT member for over 7 years!

  8. #8
    Join Date
    Aug 2002
    Location
    United Kingdom
    Posts
    290
    Quote Originally Posted by kootta View Post
    ther's a plugin to play such kind of video i think its windows media player plugin for firefox intall it and see
    Free +1 post for you!
    DesignBear.com
    View Portfolio

    A trusted WHT member for over 7 years!

  9. #9
    i have the screen shot attached. the screen shot is from firefox browser. the buttons show up fine in explorer, but it doesn't show up in firefox
    Attached Thumbnails Attached Thumbnails screen_shot.jpg  

  10. #10
    Join Date
    Aug 2002
    Location
    United Kingdom
    Posts
    290
    Never seen that before. Certainly doesn't show up in my firefox version (latest).
    DesignBear.com
    View Portfolio

    A trusted WHT member for over 7 years!

  11. #11
    Hiya I looking on the internet, and there are others that are having your problem i saw one and sombody posted this,

    you can try it but i can't garentee it to work.

    <!--[if !IE]> <-->
    <object type="video/x-ms-wmv" data="http://mydomain.com/video.wmv" width="320px" height="240px">
    <param name="src" value="http://mydomain.com/video.wmv" valuetype="ref" type="http://mydomain.com/video.wmv">
    <param name="animationatStart" value="1">
    <param name="transparentatStart" value="1">
    <param name="autoStart" value="1">
    <param name="ShowControls" value="0">
    <param name="ShowDisplay" value="0">
    <param name="ShowStatusBar" value="0">
    <param name="loop" value="0">
    <param name="displaysize" value="0">
    <strong>Error:</strong> Embedding <a href="http://mydomain.com/video.wmv">http://mydomain.com/video.wmv</a> with the <a href="http://www.microsoft.com/windows/windowsmedia/download/plugin.aspx">Windows Media Plugin</a> failed.
    </object>
    <!--> <![endif]-->
    <!--[if IE]>
    <object type="video/x-ms-wmv" classid="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95" width="320px" height="240px">
    <param name="src" value="http://mydomain.com/video.wmv" valuetype="ref" type="video/x-ms-wmv">
    <param name="animationatStart" value="1">
    <param name="transparentatStart" value="1">
    <param name="autoStart" value="1">
    <param name="ShowControls" value="0">
    <param name="ShowDisplay" value="0">
    <param name="ShowStatusBar" value="0">
    <param name="loop" value="0">
    <param name="displaysize" value="0">
    <strong>Error:</strong> Embedding <a href="http://mydomain.com/video.wmv">http://mydomain.com/video.wmv</a> with the Windows Media Plugin failed. Make sure you have <a href="http://www.microsoft.com/windows/windowsmedia/default.aspx">Windows Media Player</a>.
    </object>
    <![endif]-->

  12. #12
    Join Date
    Aug 2002
    Location
    United Kingdom
    Posts
    290
    He's using the new video renderer and code though so he's no longer embedding WMV files. Really my best guess would be to tell you to upgrade your flash version on firefox - give that a go and let me know what happens.

    Cheers.
    DesignBear.com
    View Portfolio

    A trusted WHT member for over 7 years!

Similar Threads

  1. Firefox video :) (merged)
    By XF-Chan in forum Web Hosting Lounge
    Replies: 28
    Last Post: 06-08-2006, 09:49 AM
  2. Firefox won't show website, cache?
    By ANelfNAMEDwallet in forum Web Design and Content
    Replies: 4
    Last Post: 01-19-2006, 09:46 PM
  3. css doesn't show properly in firefox
    By crazyfish in forum Web Design and Content
    Replies: 9
    Last Post: 01-22-2005, 12:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •