Results 1 to 12 of 12

Thread: Ram Problem

  1. #1

    Ram Problem

    dear
    i have a dedicated server with Centos 5.2 32bit.
    my cpu is 64bit but for some software , datacenter install 32bit for me.
    i need more ram and order to datacenter , before my ram was 4 Gig and now my ram is 6 gig . but cpu just use 3 gig of ram.

    i install kernel-PAE with "yum install kernel-PAE " command and my ram down to 2.5 Gig . now my server used just 2.5 gig of ram.
    what do it do ?
    i can not reformat server because of i have some vps in this server ( Xen vps )
    please help me.
    thanks
    Colocation, Dedicated Server, Cloud Services

  2. #2
    Join Date
    Mar 2009
    Location
    Gods Own Country
    Posts
    681
    post the result of "free -m" here

  3. #3
    total used free shared buffers cached
    Mem: 2444 1734 709 0 522 923
    -/+ buffers/cache: 288 2155
    Swap: 2047 0 2047
    Colocation, Dedicated Server, Cloud Services

  4. #4
    Join Date
    Mar 2009
    Location
    Gods Own Country
    Posts
    681
    post "uname -a" result too

  5. #5
    Linux **** 2.6.18-92.1.22.el5xen #1 SMP Tue Dec 16 13:08:49 EST 2008 i686 i686 i386 GNU/Linux
    Colocation, Dedicated Server, Cloud Services

  6. #6
    Join Date
    Mar 2009
    Location
    Gods Own Country
    Posts
    681
    the kernel is not a PAE kernel.. boot into PAE kernel

  7. #7
    i need Xen kernel.
    i have vps in this kernel.
    if i boot from PAE , all vps not running
    Colocation, Dedicated Server, Cloud Services

  8. #8
    can i use another way to use my ram ?
    Colocation, Dedicated Server, Cloud Services

  9. #9
    Join Date
    Mar 2009
    Location
    Gods Own Country
    Posts
    681
    you need to install xenpae kernel.. ordinary 32-bit kernel can only address only 4GB memory

  10. #10
    i can not find xenpae in yum install.
    can you say the install command ?
    thanks a lot for help me
    Colocation, Dedicated Server, Cloud Services

  11. #11
    Join Date
    Mar 2009
    Location
    Gods Own Country
    Posts
    681
    In debian, xen kernel used to support PAE..

    post the result of "yum list | grep -i xen" and "yum list | grep -i pae"

  12. #12
    Join Date
    Mar 2009
    Location
    Gods Own Country
    Posts
    681
    I was wrong

    http://www.centos.org/modules/newbb/...topic_id=12690

    According to the Centos support Wiki, the Xen kernel that ships with Centos 5.1 supports PAE
    and 5.2 xen should also support PAE. So, it looks like you have a faulty RAM in your server. You need to get it checked by your NOC guys.

Similar Threads

  1. Domain Problem , Hosting Problem or Security Problem?
    By xoleno in forum Hosting Security and Technology
    Replies: 0
    Last Post: 03-31-2008, 05:41 AM
  2. Problem with installing HyperVM on CentOS (Problem w/ YUM?)
    By DennisM in forum Hosting Security and Technology
    Replies: 4
    Last Post: 11-05-2007, 09:05 PM
  3. Software Problem on Dedicated Server...Not a Problem on Shared??
    By ekusteve in forum Hosting Security and Technology
    Replies: 4
    Last Post: 06-14-2005, 12:35 PM
  4. php problem? Apache problem? Mime? Script can't do upload....
    By galacnet in forum Hosting Security and Technology
    Replies: 7
    Last Post: 05-30-2005, 11:15 AM
  5. Large problem with domains displaying wrong problem.
    By NationHosts in forum Hosting Security and Technology
    Replies: 3
    Last Post: 01-20-2004, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •