Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2004

    Applying CSS Link Attributes to only Images Issue

    I am trying to code something in CSS where a href link properties I designate only applies to all images on the specific page. What I am trying to achieve is no border when the mouse does not hover over the image, but a border shows when the mouse hovers over the image link. For some reason the hover part works but the default border color defaults to a blue border color. I can't seem to make it so the non hover link has a border attribute of none or at least white so it's transparent wtih the background. Any help would be appreciated.

    Here it is what I have so far:

    a: img {
    text-decoration: none;
    border: none;
    border-color: #FFF;
    a:hover img {
    border-color: #000;
    “Intelligence is not to make no mistakes, but quickly to see how to make them good.” - Bertolt Brecht

  2. #2
    Join Date
    Feb 2003
    a img {
      border: 0px;
    a:hover img {
      border: 1px solid #000;
    Looked like your non-hover style might not of been valid, due to a : selector without an attribute?

Similar Threads

  1. Copyright issue with Getty images [SPLIT]
    By Dori1975 in forum Web Design and Content
    Replies: 40
    Last Post: 05-23-2008, 11:09 AM
  2. Weird GoDaddy Issue with Images
    By phatchamp in forum Web Hosting
    Replies: 7
    Last Post: 02-28-2008, 11:23 PM
  3. .htaccess Issue With Images In New Window
    By war59312 in forum Programming Discussion
    Replies: 2
    Last Post: 02-05-2006, 04:59 AM
  4. Domain/IP images issue
    By ripdepot in forum Hosting Security and Technology
    Replies: 4
    Last Post: 07-10-2004, 07:48 PM
  5. Replies: 1
    Last Post: 06-19-2003, 02:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts