Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2004

    Sub Domain on Different Server Exim Unroutable Address - WHM/cPanel

    Hi, I have two servers running cPanel/WHM, with BIND and Exim. I have my main domain running on one server ( and wish to host a seperate helpdesk on a subdomain (on a second server,

    The subdomain mail account [email protected] works fine with hotmail, i can send and reveive between my server and hotmail without any issue.

    The problem is when i try and send mails from accounts hosted on, to the subdomain server, i get the following unroutable address error fired back by the local exim process:

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

     [email protected]
        Unrouteable address
    ------ This is a copy of the message, including all the headers. ------
    Return-path: <[email protected]>
    Received: from [] (helo=cartman)
    	by with esmtpa (Exim 4.69)
    	(envelope-from <[email protected]>)
    	id 1MVuGJ-0004h0-3p
    	for [email protected]; Tue, 28 Jul 2009 22:31:07 +0100
    From: "Chris Morley" <[email protected]>>
    To: <[email protected]>
    Date: Wed, 29 Jul 2009 01:32:57 +0400
    Message-ID: <[email protected]>

    I have setup the subdomain in WHM, with the following bind zone as follows (this is a DNS cluster so zone files are the same on both gizmo and stripe):

    [email protected] [/var/named]# cat
    ; cPanel first:11.24.4-RELEASE_36167 latest:11.24.4-NIGHTLY_36950 Cpanel::ZoneFile::VERSION:1.2 mtime:1248815949
    ; Zone file for
    $TTL 14400        86400   IN      SOA       (
                                                    2009071311 ;Serial Number
                                                    86400 ;refresh
                                                    7200 ;retry
                                                    3600000 ;expire
                                                    86400 ;minimum
            )        86400   IN      NS        86400   IN      NS        14400   IN      A
    localhost       14400   IN      A        14400   IN      MX      0
    mail    14400   IN      CNAME
    www     14400   IN      CNAME
    ftp     14400   IN      A
    cpanel  14400   IN      A
    whm     14400   IN      A
    webmail 14400   IN      A
    webdisk 14400   IN      A
    support 14400   IN      A
    support 14400   IN      MX      0        14400   IN      A

    The exim dump on gizmo is as follows:

    [email protected] [~]# tail -n 50 /var/log/exim_mainlog
    2009-07-28 22:31:07 1MVuGJ-0004h0-3p <= [email protected] H=(cartman) [] P=esmtpa A=fixed_login:[email protected] S=5457 [email protected]
    2009-07-28 22:31:07 1MVuGJ-0004h0-3p ** [email protected]: Unrouteable address
    2009-07-28 22:31:07 1MVuGJ-0004hJ-Ix <= <> R=1MVuGJ-0004h0-3p U=mailnull P=local S=6360
    2009-07-28 22:31:07 1MVuGJ-0004h0-3p Completed
    2009-07-28 22:31:07 1MVuGJ-0004hJ-Ix => csmorley <[email protected]> R=virtual_user T=virtual_userdelivery
    2009-07-28 22:31:07 1MVuGJ-0004hJ-Ix Completed
    When i try and send from stripe (the server that hosts the subdomain to an email address as the main parent domain (hosted on gizmo), i get the following failure:

    [email protected]
        SMTP error from remote mail server after RCPT TO:<[email protected]>:
        host []:
        550-Verification failed for <[email protected]>
        550-Unrouteable address
        550 Sender verify failed
    The dump exim dump from the main domain machine is as follows:

    [email protected] [~]# tail -n 50 /var/log/exim_mainlog
    2009-07-28 22:32:19 [] Warning: Sender rate 4.6 / 1h
    2009-07-28 22:32:19 [] sender verify fail for <[email protected]>: Unrouteable address
    2009-07-28 22:32:19 [] F=<[email protected]> rejected RCPT <[email protected]>: Sender verify failed

    Does anyone have any idea what is going on with the above? Been scratching my head and googling for a while but so far have drawn a blank.

    Many thanks in advance,


  2. #2
    Join Date
    Aug 2004
    Hi, just to let everyone know managed to resolve this:


  3. #3
    Join Date
    Jul 2009
    Yes, /etc/localdomains and remotedomain should be configured properly in order to send e-mails properly. That's why you need to move to remotedoamins and everything should work properly.

Similar Threads

  1. email unroutable address problem
    By shaggyboiler in forum Hosting Security and Technology
    Replies: 2
    Last Post: 08-27-2008, 04:54 PM
  2. 550 error unroutable address
    By clrockwell in forum Hosting Security and Technology
    Replies: 6
    Last Post: 07-12-2008, 02:31 PM
  3. Unroutable Address Error
    By berdo9DS in forum Hosting Security and Technology
    Replies: 14
    Last Post: 10-05-2006, 05:50 PM
  4. Unroutable Address Error
    By MarshallT in forum Hosting Security and Technology
    Replies: 10
    Last Post: 10-11-2004, 01:58 AM
  5. Unroutable domain error
    By mayaweb in forum Web Hosting
    Replies: 6
    Last Post: 07-12-2004, 09:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts