Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2007
    Posts
    445

    problem with XEN installation

    Hi
    when i run command :
    Yum xen install
    show this error:

    Code:
    xen-3.0.3-80.el5_3.3.x86_64 from updates has depsolving problems
      --> Missing Dependency: xen-hypervisor-abi = 3.1 is needed by package xen-3.0.3-80.el5_3.3.x86_64 (updates)
    Error: Missing Dependency: xen-hypervisor-abi = 3.1 is needed by package xen-3.0.3-80.el5_3.3.x86_64 (updates)

  2. #2
    Join Date
    Feb 2004
    Location
    UK
    Posts
    1,429
    Hi

    Have you tried

    yum install xen*

    Thanks

  3. #3
    Join Date
    Jul 2007
    Posts
    445
    Yes
    Code:
    # yum install xen
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    --> Running transaction check
    ---> Package xen.x86_64 0:3.0.3-80.el5_3.3 set to be updated
    --> Processing Dependency: xen-hypervisor-abi = 3.1 for package: xen
    --> Processing Dependency: xen-libs = 3.0.3-80.el5_3.3 for package: xen
    --> Processing Dependency: python-virtinst for package: xen
    --> Processing Dependency: libfsimage.so.1.0(libfsimage.so.1.0)(64bit) for package: xen
    --> Processing Dependency: bridge-utils for package: xen
    --> Processing Dependency: libfsimage.so.1.0()(64bit) for package: xen
    --> Processing Dependency: libSDL-1.2.so.0()(64bit) for package: xen
    --> Processing Dependency: libxenctrl.so.3.0()(64bit) for package: xen
    --> Processing Dependency: libxenstore.so.3.0()(64bit) for package: xen
    --> Processing Dependency: libblktap.so.3.0()(64bit) for package: xen
    --> Processing Dependency: libxenguest.so.3.0()(64bit) for package: xen
    --> Running transaction check
    ---> Package xen.x86_64 0:3.0.3-80.el5_3.3 set to be updated
    --> Processing Dependency: xen-hypervisor-abi = 3.1 for package: xen
    ---> Package xen-libs.x86_64 0:3.0.3-80.el5_3.3 set to be updated
    ---> Package bridge-utils.x86_64 0:1.1-2 set to be updated
    ---> Package SDL.x86_64 0:1.2.10-8.el5 set to be updated
    --> Processing Dependency: libXext.so.6()(64bit) for package: SDL
    --> Processing Dependency: libesd.so.0()(64bit) for package: SDL
    --> Processing Dependency: libXrender.so.1()(64bit) for package: SDL
    --> Processing Dependency: libXrandr.so.2()(64bit) for package: SDL
    --> Processing Dependency: libX11.so.6()(64bit) for package: SDL
    --> Processing Dependency: libaudiofile.so.0()(64bit) for package: SDL
    ---> Package python-virtinst.noarch 0:0.300.2-12.el5 set to be updated
    --> Processing Dependency: libvirt-python >= 0.2.1 for package: python-virtinst
    --> Running transaction check
    ---> Package libXrender.x86_64 0:0.9.1-3.1 set to be updated
    ---> Package audiofile.x86_64 1:0.2.6-5 set to be updated
    ---> Package libXrandr.x86_64 0:1.1.1-3.1 set to be updated
    ---> Package xen.x86_64 0:3.0.3-80.el5_3.3 set to be updated
    --> Processing Dependency: xen-hypervisor-abi = 3.1 for package: xen
    ---> Package esound.x86_64 1:0.2.36-3 set to be updated
    --> Processing Dependency: libasound.so.2(ALSA_0.9)(64bit) for package: esound
    --> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4)(64bit) for package: esound
    --> Processing Dependency: libasound.so.2()(64bit) for package: esound
    ---> Package libXext.x86_64 0:1.0.1-2.1 set to be updated
    --> Processing Dependency: libXau.so.6()(64bit) for package: libXext
    ---> Package libvirt-python.x86_64 0:0.3.3-14.el5_3.1 set to be updated
    --> Processing Dependency: libvirt = 0.3.3 for package: libvirt-python
    --> Processing Dependency: libvirt.so.0()(64bit) for package: libvirt-python
    ---> Package libX11.x86_64 0:1.0.3-9.el5 set to be updated
    --> Processing Dependency: xorg-x11-filesystem >= 0.99.2-3 for package: libX11
    --> Processing Dependency: libXdmcp.so.6()(64bit) for package: libX11
    --> Running transaction check
    ---> Package alsa-lib.x86_64 0:1.0.17-1.el5 set to be updated
    ---> Package libXau.x86_64 0:1.0.1-3.1 set to be updated
    ---> Package xen.x86_64 0:3.0.3-80.el5_3.3 set to be updated
    --> Processing Dependency: xen-hypervisor-abi = 3.1 for package: xen
    ---> Package xorg-x11-filesystem.noarch 0:7.1-2.fc6 set to be updated
    ---> Package libvirt.x86_64 0:0.3.3-14.el5_3.1 set to be updated
    --> Processing Dependency: dnsmasq for package: libvirt
    --> Processing Dependency: libavahi-common.so.3()(64bit) for package: libvirt
    --> Processing Dependency: libavahi-client.so.3()(64bit) for package: libvirt
    ---> Package libXdmcp.x86_64 0:1.0.1-2.1 set to be updated
    --> Running transaction check
    ---> Package dnsmasq.x86_64 0:2.45-1.el5_2.1 set to be updated
    ---> Package avahi.x86_64 0:0.6.16-1.el5_2.1 set to be updated
    --> Processing Dependency: libdaemon for package: avahi
    --> Processing Dependency: libdaemon.so.0()(64bit) for package: avahi
    ---> Package xen.x86_64 0:3.0.3-80.el5_3.3 set to be updated
    --> Processing Dependency: xen-hypervisor-abi = 3.1 for package: xen
    --> Running transaction check
    ---> Package libdaemon.x86_64 0:0.10-5.el5 set to be updated
    ---> Package xen.x86_64 0:3.0.3-80.el5_3.3 set to be updated
    --> Processing Dependency: xen-hypervisor-abi = 3.1 for package: xen
    --> Finished Dependency Resolution
    xen-3.0.3-80.el5_3.3.x86_64 from updates has depsolving problems
      --> Missing Dependency: xen-hypervisor-abi = 3.1 is needed by package xen-3.0.3-80.el5_3.3.x86_64 (updates)
    Error: Missing Dependency: xen-hypervisor-abi = 3.1 is needed by package xen-3.0.3-80.el5_3.3.x86_64 (updates)

Similar Threads

  1. problem on php installation
    By surfmanjoe in forum Hosting Security and Technology
    Replies: 3
    Last Post: 08-08-2008, 06:11 AM
  2. New installation problem
    By jcrespi in forum Dedicated Server
    Replies: 1
    Last Post: 03-24-2004, 01:36 AM
  3. PHP installation problem
    By dxoxb in forum Programming Discussion
    Replies: 4
    Last Post: 10-26-2003, 04:42 AM
  4. web-cp installation problem
    By ryankf in forum Hosting Software and Control Panels
    Replies: 8
    Last Post: 08-24-2002, 07:47 PM
  5. SSL Installation problem with WHM.
    By ^Phi in forum Hosting Security and Technology
    Replies: 4
    Last Post: 04-01-2002, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •