Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2008

    PLEASE Help- Wordpress Question

    Hi all,

    I am using the Wp-Freemium theme, which is great, but it is having a problem when viewed with Internet Explorer.

    The problem:

    The navigation menu does not display in a straight line. It displays in a decending line. The second link is displayed below and beside the first, and so on, until the rest just disappears.

    Because of this the whole menu won't display. I have provided the header code below if that helps.

    Cheers to anyone who can offer a resulution to this problem!!

    Header code:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "">
    <!--BEGIN html-->
    <html xmlns="" <?php language_attributes(); ?>>
    Designed and builted by Ptah Dunbar -
    Download this WordPress Theme @
    <!--BEGIN head-->
    <head profile="">
    <title><?php wpf_generate_title_tag(); ?></title>

    <!-- Meta Tags -->
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    <meta name="generator" content="WordPress" />
    <meta name="description" content="<?php bloginfo('description'); ?>" />
    <meta name="copyright" content="<?php the_time('Y'); ?>" />

    <!-- Favicon: Browser + iPhone Webclip -->
    <link rel="shortcut icon" href="<?php echo bloginfo('template_directory') . '/images/favicon.ico'; ?>" />
    <link rel="apple-touch-icon" href="<?php echo bloginfo('template_directory') . '/images/iphone.png'; ?>"/>

    <!-- Stylesheets: Screen + Print -->
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen, projection" />
    <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/print.css" type="text/css" media="print">
    <!--[if IE]>
    <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/ie.css" type="text/css" media="screen, projection">

    <!-- RSS - Subscribe to <?php bloginfo('name') ?> via RSS
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="alternate" type="text/xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    <link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="<?php bloginfo('atom_url'); ?>" />

    <!-- Pingback -->
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

    <!-- WP_Head -->
    <?php wp_head(); ?>
    <!--END head-->
    <!--BEGIN body-->
    <!--BEGIN #wpfreemium-theme-->
    <div id="wpfreemium-theme" class="container">

    <!--BEGIN #header-->
    <div id="header" class="span-24">
    <h1 id="logo"><a href="<?php bloginfo('url'); ?>"><img src="<?php echo bloginfo('template_directory') . '/images/Presale.png'; ?>" width="401" height="75" alt="" /></a></h1>
    <?php include (TEMPLATEPATH . "/searchform.php"); ?>

    <!--END #header-->

    <!--BEGIN #navigation-->
    <div id="navigation" class="span-24">
    <?php wp_list_pages('sort_column=menu_order&depth=0&title_li='); ?>
    <li id="rss-link"><a href="<?php bloginfo('rss2_url'); ?>">Subscribe via RSS</a></li>


    <!--BEGIN #sub-navigation-->
    <div id="sub-navigation" class="span-24">
    <?php wp_list_categories('title_li=&show_last_updated=1'); ?>
    <!--END #navigation-->

    <!--END #sub-navigation-->

  2. #2
    Join Date
    Jun 2009
    UK: Oxford
    Try putting it in a table. Simple things like that might set it right. Other then that, I cant think of anything else that would alter it's direction.
    Garbott Ltd - Professional web development & consultancy services
    Oxford.Hosting - Prestigious shared, cloud, dedicated and gaming hosting solutions.

  3. #3
    Join Date
    Feb 2006
    you might want to post your css for the navigation
    <<< Please see Forum Guidelines for signature setup. >>>

  4. #4
    Join Date
    May 2008
    Tampa, Florida
    ok here is the steps you need to do first in order to get some good wordpress answers.

    1. post your site URL or PM people who ask about it
    2. post your CSS as Coreymade said
    3. ask the designer who made it to check it out and provide an updated version to fix the issue/bug

    hope those steps will help with getting it resolved, btw please pm the site so maybe i can help as well - Shoutcast Streams & Web Hosting
    █ Custom Streams Available - Contact me - We're in Second Life Too!
    Real Quality - Real Support - Real Affordable since 2008!

  5. #5
    Join Date
    Jun 2008
    My site is:

    My css (don't know how much this helps):

    Theme Name: WP Freemium Theme
    Theme URL:
    Description: Maded orginally for, this is a WordPress theme designed for multi-authored blogs. Designed and developed by <a href="">Ptah Dunbar</a>.
    Version: 2.0

    Author: Ptah Dunbar
    Author URI:
    Tags: Bloggingtips, widgets, multi-authored blog, Ptah Dunbar

    If you have any questions, comments, or concerns, send me an email to [email protected]
    For licensing agreements check the _license.txt file (GPL).


    * v2.0 - 07.27.08
    Completely revamped the backend along with a UI face lift. Using Blueprint's CSS framework and grid system.
    * v1.3 - 05.31.08
    Bug fixed in single.php - It didn�t generate the author�s promotion section with the correct author.
    To fix, move �<?php include (TEMPLATEPATH . '/addons/author-metadata.php'); ?>� on line 51 in single.php file above the loop, anywhere above line 8
    * v1.2 - 05.29.08
    IE Bug prevented the logo from being displayed. To fix, just remove �h1#logo a { text-indent: -9999px; }� in header.php on line 31
    * v1.1 - 05.28.08
    Typo, spelled Administrator wrong in author.php on line 25 (Adminitrator)
    * v0.1 - 05.27.08
    First Release of WPFramework

    /* Reset Browser Defaults (css/reset.css) */
    @import url(css/reset.css);

    /* Base Stylesheet (css/base.css) */
    @import url(css/base.css);

    /* Site Specific Styles (css/screen.css) */
    @import url(css/screen.css);

    /* HTML helpers *//*

    <!--BEGIN #-->
    <div id="">

    <!--END #-->

    <!--BEGIN .-->
    <div class="">

    <!--END .-->

    <!--BEGIN # .-->
    <div id="" class="">

    <!--END .-->


  6. #6
    if your talking about the presale passwords menu item being under the main menu its because its in a submenu div you probably just need to login to wordpress and fix where the menu is supposed to show up.

  7. #7
    i think it's just a lack of full support for ie in the site's css, optimizing the site to look just right in that pile we call iexplorer(6 & lower) has been a headache for web developers for a long time now...

Similar Threads

  1. PLEASE Help- Wordpress Question
    By aqaz69 in forum Web Design and Content
    Replies: 0
    Last Post: 07-23-2009, 07:17 PM
  2. Wordpress Question
    By aqaz69 in forum Web Design and Content
    Replies: 3
    Last Post: 09-10-2008, 09:07 AM
  3. Another Wordpress Question
    By aqaz69 in forum Web Design and Content
    Replies: 2
    Last Post: 07-16-2008, 03:46 AM
  4. Wordpress question- please Help!!
    By aqaz69 in forum Web Design and Content
    Replies: 4
    Last Post: 07-15-2008, 10:08 AM
  5. Wordpress question
    By aqaz69 in forum Web Design and Content
    Replies: 1
    Last Post: 06-28-2008, 09:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts