Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2004

    Server network very slow, need help


    I have strange problem with my server running CentOS 5.3.

    I noticed that there are huge pings to my server from time to time, example:

    64 bytes from HOSTNAME (server-IP): icmp_seq=0 ttl=60 time=2.93 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=1 ttl=60 time=2.70 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=2 ttl=60 time=1901 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=3 ttl=60 time=899 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=5 ttl=60 time=2.69 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=6 ttl=60 time=2.62 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=4 ttl=60 time=2132 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=8 ttl=60 time=2.57 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=7 ttl=60 time=1190 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=10 ttl=60 time=2.65 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=9 ttl=60 time=1048 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=12 ttl=60 time=2.74 ms
    64 bytes from HOSTNAME (server-IP): icmp_seq=11 ttl=60 time=1205 ms

    First I thought that it is network related, but most strange for me was that I did not have any packets lose.

    Then I tried to ping from my server to other hosts - situation was the same - some ping were good and some were huge (700ms, 800ms, even 2000ms)

    I checked:
    cat /proc/sys/net/ipv4/netfilter/ip_conntrack_max
    and it was 65536

    Then I checked:
    cat /proc/sys/net/ipv4/netfilter/ip_conntrack_count
    and it was ~1600 so normal.

    dmesg was showing such errors:

    conntrack_ftp: partial 227 3331059707+13

    Then I checked ifconfig, here is the output:

    eth0 Link encap:Ethernet HWaddr 00:24:21:57:2B:6F
    inet addr:MAIN=IP Bcast:BCAST=IP Mask:
    inet6 addr: fe80::224:21ff:fe57:2b6f/64 Scope:Link
    RX packets:170557113 errors:0 dropped:2421127049 overruns:0 frame:0
    TX packets:182047660 errors:0 dropped:46 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2756835074 (2.5 GiB) TX bytes:79640621 (75.9 MiB)
    Interrupt:82 Base address:0xe000

    Strange for me was:

    RX packets [...] dropped:2421127049
    TX packets [...] dropped:46

    I did not have such dropped information on all my other servers. Dropped counter for RX was constatnly increasing.

    So I decided to restart all services on the server. After restarting network and ipaliases - problem disappeared. RX dropped counter is still rising, but I do not have any slowdowns on the server and pings are normal.

    My question is - does anyone could have any idea what can casue my problem and how can I prevent this in the future?


  2. #2
    Join Date
    Mar 2009
    Chicago, IL
    You should contact your DC and have them verify if there are any errors on your switchport or not. I'd start with that. It could be a bad cable, nic going bad, possibly a bad switchport or network config as well. However in a good setup you shouldn't be dropping packets like that.

    Also do you have any errors regarding iptables when you type 'dmesg' or in /var/log/messages out of curiosity?

  3. #3
    Join Date
    Oct 2004

    Thank you for your reply.

    I do not have any errors from iptables in dmesg and /var/log/messages - there are only common information from csf firewall.

    The most strange thing for me was that this server was working well for one week (it is new server), and after restarting network/ipaliases services - works well to (but RX dropped counter is rising very fast - right now RX dropped counter is higher then it was before I restarted netowork service , but server is still working well)

  4. #4
    Join Date
    Oct 2004
    Is there any explanation why 'service network restart' and 'service iptables restart' solved those high pings on my server?

  5. #5
    Join Date
    Oct 2004

    I just started to check ipconfig and RX packets drop counter, and it is not only growing but it is lowering as well, here are examples - I took each next after 30-40 seconds:


    So each 30-40 seconds RX dropped packets counter is growing or lowering.

  6. #6
    I'm encountering the exact same issue. Did you ever find a solution to this ? Running "service network restart" restores my speeds, but within 24 hrs they quickly degrade back to sub-1kb/sec and very high pings, to a point where SSH is barely usable due to extreme lag.

    I'm on a Realtek RTL8111/8168B card, would yours happen to be the same ? Could be a driver glitch.

Similar Threads

  1. slow network one specific server
    By Calibaba in forum Hosting Security and Technology
    Replies: 7
    Last Post: 11-19-2008, 05:38 AM
  2. Server network speed gets very slow then unconnectable
    By YYamagishi in forum Hosting Security and Technology
    Replies: 2
    Last Post: 03-05-2008, 04:33 AM
  3. scp VERY slow network preformance?
    By nkad in forum Hosting Security and Technology
    Replies: 10
    Last Post: 10-04-2007, 02:07 AM
  4. is the network slow?
    By brian73 in forum Dedicated Server
    Replies: 20
    Last Post: 10-20-2006, 03:18 PM
  5. Nocster network slow right now?
    By Maxplayer14 in forum Dedicated Server
    Replies: 30
    Last Post: 10-19-2003, 11:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts