Results 1 to 13 of 13

Thread: few errors

  1. #1
    Join Date
    Oct 2008
    Posts
    2,249

    few errors

    Well a guy tqpoint on my msn was having 2 issues on his vps.

    1. each time he tried to log into his squirralmail he got : connection dropped my imap server

    2. On his centos vps yum install phpmyadmin doesnt work. So I offered to help. my normal way of doing it didnt work and neither did a guide i found that said to do this:NOTE: Version 3.0 and greater require php version 5.2.

    1. If you haven't already done so, start MySQL.
    2. Its time to set the root password.
    > /usr/bin/mysqladmin -u root password 'thepassword'
    > /usr/bin/mysqladmin -p -u root -h localhost.localdomain password 'thepassword'
    3. Download the latest version of phpMyAdmin from www.phpmyadmin.net
    > wget http://prdownloads.sourceforge.net/p...ar.gz?download
    4. unpack the package
    > tar -xzvf phpMyAdmin-3.2.0-english.tar.gz
    5. Move it to the appropriate place.
    > mv phpMyAdmin-3.2.0-english /usr/share/phpMyAdmin
    6. Create the apache config file for phpmyadmin and restart apache.
    > echo "alias /webdb /usr/share/phpMyAdmin" > /etc/httpd/conf.d/phpMyAdmin.conf
    > service httpd restart
    7. Configure phpMyAdmin
    > cd /usr/share/phpMyAdmin
    > cp libraries/config.default.php config.inc.php
    > nano -w config.inc.php
    8. Locate each of the following lines and be sure each has the following settings.
    $cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (con$
    $cfg['Servers'][$i]['user'] = 'root'; // MySQL user
    $cfg['Servers'][$i]['password'] = ''; // MySQL password (only nee$
    9. Save the file.
    10. now test it out.



    now going to thedomain.com/phpmyadmin it says there is no directory



    any ideas? I tried helping him and was unable to solve it. not 100% sure everything he has tried so I cant do much
    Leader of the new anti sig spamming club.

  2. #2
    Join Date
    Mar 2009
    Posts
    36
    According to that guide you posted, you need to use <domain>/webdb.

  3. #3
    Join Date
    May 2007
    Location
    Canada
    Posts
    183
    Just looking at that code above, you should try visiting :

    thedomain.com/webdb

    For PhpMyAdmin access. Also, make sure you restart httpd, so the changes can take effect.
    Quality Hosting - http://www.robohostingsolutions.com
    My Blog - http://solidservers.ca
    Freelance Server Administration (decent rates!) - Chris(at)SolidServers.ca

  4. #4
    Join Date
    Oct 2008
    Posts
    2,249
    now its saying php 5.2+ is required but its already in there. this guy mustive messed it up big time.

    EDIT I just ran yum update php apprently its up to date but php -v shows its 5.1.2
    Last edited by darkeden; 06-19-2009 at 11:04 PM.
    Leader of the new anti sig spamming club.

  5. #5
    Join Date
    Mar 2009
    Posts
    36
    Perhaps try updating PHP just in case?
    (yum update php)

  6. #6
    Join Date
    Oct 2008
    Posts
    2,249
    Quote Originally Posted by Webbify View Post
    Perhaps try updating PHP just in case?
    (yum update php)
    already tried says its up to date
    Leader of the new anti sig spamming club.

  7. #7
    Join Date
    Feb 2008
    Location
    Houston, Texas, USA
    Posts
    2,955
    Quote Originally Posted by darkeden View Post
    already tried says its up to date
    Make sure php is not being excluded in /etc/yum.conf. Also, what CentOS version are you running?
    UNIXy - Fully Managed Servers and Clusters - Established in 2006
    [ cPanel Varnish Nginx Plugin ] - Enhance LiteSpeed and Apache Performance
    www.unixy.net - Los Angeles | Houston | Atlanta | Rotterdam
    Love to help pro bono (time permitting). joe > unixy.net

  8. #8
    Join Date
    Mar 2009
    Posts
    36
    Try downloading a slightly older version of PHPMA off their site. I know a fairly recent one allows older PHP's (not sure which).

  9. #9
    Join Date
    Mar 2009
    Posts
    36
    (By the way, 5.1.6 is latest PHP in CentOS 5.2 apparently.)

  10. #10
    Join Date
    Oct 2008
    Posts
    2,249
    Quote Originally Posted by Webbify View Post
    (By the way, 5.1.6 is latest PHP in CentOS 5.2 apparently.)
    that would mean every centos webhost I have been with... is using an older centos and phpmyadmin.



    Still cant fix the mail part but I think phpmyadmin is fixed. I edited the version name even though its still 5.1.6 so atleast phpmyadmin is working now.
    Leader of the new anti sig spamming club.

  11. #11
    Join Date
    Oct 2008
    Posts
    2,249
    Quote Originally Posted by UNIXy View Post
    Make sure php is not being excluded in /etc/yum.conf. Also, what CentOS version are you running?
    hes running the lattest 5.3 version from the looks of cat /etc/redhat-release


    and /etc/yum.conf doesnt say anything besides [main]
    cachedir=/var/cache/yum
    keepcache=0
    debuglevel=2
    logfile=/var/log/yum.log
    distroverpkg=redhat-release
    tolerant=1
    exactarch=1
    obsoletes=1
    gpgcheck=1
    plugins=1



    wow his vps is messed




    Im thinking I may backup the config files he has done that work fine and build him a custom centos version that would be easier for him to handle.
    Last edited by darkeden; 06-20-2009 at 11:33 AM.
    Leader of the new anti sig spamming club.

  12. #12
    Join Date
    May 2007
    Location
    Canada
    Posts
    183
    What is listed in the /etc/yum.repos.d/ directory? If you have something in there, be sure to check that for excludes as well. Does this VPS have a control panel with it?
    Quality Hosting - http://www.robohostingsolutions.com
    My Blog - http://solidservers.ca
    Freelance Server Administration (decent rates!) - Chris(at)SolidServers.ca

  13. #13
    Verify that you have set the Alias for /phpmyadmin to default document root of phpmyadmin in your webserver configuration file.

    Ben

Similar Threads

  1. Email Errors - 550 Callback errors
    By truenegative in forum Hosting Security and Technology
    Replies: 5
    Last Post: 02-15-2007, 10:43 AM
  2. Errors
    By UnrealSilence in forum Hosting Security and Technology
    Replies: 6
    Last Post: 03-24-2006, 01:16 PM
  3. CGI Errors
    By ITGEEK in forum Programming Discussion
    Replies: 10
    Last Post: 07-05-2003, 09:35 PM
  4. need to ask about dns errors
    By gtrplayer in forum Hosting Security and Technology
    Replies: 4
    Last Post: 01-12-2003, 01:21 PM
  5. Getting errors PHP
    By Lippy in forum Programming Discussion
    Replies: 6
    Last Post: 12-02-2002, 06:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •