Results 1 to 14 of 14

Thread: yum broken?

  1. #1
    Join Date
    Oct 2008
    Posts
    2,249

    yum broken?

    Hey im trying to reinstall a few apps and no matter what i type in for yum installs i get this:Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.eecs.wsu.edu
    * updates: pubmirrors.reflected.net
    * addons: mirrors.easynews.com
    * extras: repos.lax-noc.com
    http://centos.eecs.wsu.edu/5.3/os/i3...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.
    http://pubmirrors.reflected.net/cent...ta/repomd.xml: [Errno 4] IOError: <urlopen error (101, 'Network is unreachable')>
    Trying other mirror.
    http://centos.omnispring.com/5.3/os/...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.
    http://holmes.umflint.edu/centos/5.3...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.
    http://centos.mirrors.tds.net/pub/li...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.
    http://repos.lax-noc.com/centos/5.3/...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.


    im not sure why any ideas?



    thank you
    Leader of the new anti sig spamming club.

  2. #2
    Try the following

    Code:
    service named restart
    yum repolist
    yum clean all
    yum update
    If that doesn't fix it

    Code:
    nano -w /etc/yum.conf
    Add the following:

    timeout=300

    If that doesn't work, do the following:

    Code:
    rm -f /var/lib/rpm/__db* && rpmdb -vv --rebuilddb
    Last edited by AquariusStorage; 06-18-2009 at 08:53 PM.

  3. #3
    Join Date
    Oct 2008
    Posts
    2,249
    Loading mirror speeds from cached hostfile
    * base: centos.eecs.wsu.edu
    * updates: pubmirrors.reflected.net
    * addons: mirrors.easynews.com
    * extras: repos.lax-noc.com
    http://centos.eecs.wsu.edu/5.3/os/i3...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.
    http://pubmirrors.reflected.net/cent...ta/repomd.xml: [Errno 4] IOError: <urlopen error (101, 'Network is unreachable')>
    Trying other mirror.
    still same error
    Leader of the new anti sig spamming club.

  4. #4
    Quote Originally Posted by darkeden View Post
    Loading mirror speeds from cached hostfile
    * base: centos.eecs.wsu.edu
    * updates: pubmirrors.reflected.net
    * addons: mirrors.easynews.com
    * extras: repos.lax-noc.com
    http://centos.eecs.wsu.edu/5.3/os/i3...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.
    http://pubmirrors.reflected.net/cent...ta/repomd.xml: [Errno 4] IOError: <urlopen error (101, 'Network is unreachable')>
    Trying other mirror.
    still same error
    What did you try?

    Be sure to try everything in my post I edited it.

  5. #5
    Join Date
    Oct 2008
    Posts
    2,249
    Quote Originally Posted by AquariusADMIN View Post
    What did you try?

    Be sure to try everything in my post I edited it.
    tried all of them still the same thing. even changing the timer to 300. weird it usualy starts instantly

    nevermind its working now... for some reason my csf firewall was blocking yum.
    Leader of the new anti sig spamming club.

  6. #6
    Join Date
    Feb 2008
    Location
    Houston, Texas, USA
    Posts
    2,955
    Maybe port 80 outgoing is being blocked by the firewall? Just a shot in the dark.

    Best
    Last edited by UNIXy; 06-18-2009 at 09:06 PM. Reason: advice came a bit too late :)
    UNIXy - Fully Managed Servers and Clusters - Established in 2006
    [ cPanel Varnish Nginx Plugin ] - Enhance LiteSpeed and Apache Performance
    www.unixy.net - Los Angeles | Houston | Atlanta | Rotterdam
    Love to help pro bono (time permitting). joe > unixy.net

  7. #7
    Join Date
    Feb 2008
    Location
    Houston, Texas, USA
    Posts
    2,955
    Quote Originally Posted by AquariusADMIN View Post
    Try the following


    Code:
    rm -f /var/lib/rpm/__db* && rpmdb -vv --rebuilddb
    I don't recommend the above. It could be disastrous depending on the situation. In fact, the yum error has nothing to do with rpmdb.

    Regards
    Last edited by UNIXy; 06-18-2009 at 09:04 PM.
    UNIXy - Fully Managed Servers and Clusters - Established in 2006
    [ cPanel Varnish Nginx Plugin ] - Enhance LiteSpeed and Apache Performance
    www.unixy.net - Los Angeles | Houston | Atlanta | Rotterdam
    Love to help pro bono (time permitting). joe > unixy.net

  8. #8
    Join Date
    Oct 2008
    Posts
    2,249

    Talking

    Quote Originally Posted by UNIXy View Post
    Maybe port 80 outgoing is being blocked by the firewall? Just a shot in the dark.

    Best
    Quote Originally Posted by UNIXy View Post
    I don't recommend the above. It could be disastrous depending on the situation. In fact, the yum error has nothing to do with rpmdb.

    Regards
    i did what he said didnt work but i disabled csf firewall and it worked..... i made a backup of that so if it messed up it would be ok though
    Leader of the new anti sig spamming club.

  9. #9
    Join Date
    Feb 2008
    Location
    Houston, Texas, USA
    Posts
    2,955
    Quote Originally Posted by darkeden View Post
    i made a backup of that so if it messed up it would be ok though
    Very wise.
    UNIXy - Fully Managed Servers and Clusters - Established in 2006
    [ cPanel Varnish Nginx Plugin ] - Enhance LiteSpeed and Apache Performance
    www.unixy.net - Los Angeles | Houston | Atlanta | Rotterdam
    Love to help pro bono (time permitting). joe > unixy.net

  10. #10
    Join Date
    Apr 2009
    Location
    North America
    Posts
    49
    yum has issues with some proxies. If you have a proxy set in your ENV then this could cause something similar.
    Try out my opensource software DDoS Mitigation system at http://daedalous.net/

  11. #11
    Hi,

    Before doing anything, just make sure that you can access the repos from that server. Just check it using lynx command

  12. #12
    Join Date
    Mar 2009
    Location
    Austin Tx
    Posts
    2,001
    If you edit
    /etc/yum/pluginconf.d/fastestmirror.conf

    and set
    enabled=0

    it should work.
    Your fastestmirror has an issue.
    This is the best signature in the world....Tribute!
    (It is not the best signature in the world, no. This is just a tribute)

  13. #13
    Join Date
    Oct 2008
    Posts
    2,249
    thanks guys but I already posted i disabled csf firewal and it worked that was the issue XD
    Leader of the new anti sig spamming club.

  14. #14
    Join Date
    Mar 2009
    Location
    Chicago, IL
    Posts
    219
    If you go into the CSF config you should have an option in your /etc/csf/csf.conf file for 'TCP_OUT'. Make sure you have port 80 in there and then yum should work with your firewall.

Similar Threads

  1. Glibc broken, whole server broken
    By chielsen in forum Hosting Security and Technology
    Replies: 16
    Last Post: 07-25-2004, 02:25 AM
  2. Oh My God This Thread Is Broken! Links are broken too! WHT is broken!
    By websterworld in forum Web Hosting Lounge
    Replies: 67
    Last Post: 07-12-2004, 10:13 PM
  3. Is it broken or not?
    By Artashes in forum Web Hosting Lounge
    Replies: 16
    Last Post: 04-08-2004, 01:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •