Results 1 to 15 of 15
  1. #1
    Join Date
    Jun 2009
    Posts
    79

    Why is Apache Slower then IIS 6.0

    Here Apache at http://www.punjabistation.com:81/test/ and IIS 6.0 at http://www.punjabistation.com/test/ same files one getting around 400kbps and IIS 6 getting 768kbps. Does it Apache function slower then IIS 6 on windows server 2003. Strange Issue

  2. #2
    Join Date
    Mar 2003
    Location
    WebHostingTalk
    Posts
    16,966
    No, I don't think so.

    It is a matter of optimization when it comes to Apache.
    Specially 4 You
    .
    JoneSolutions.Com ( Jones.Solutions ) is on the net 24/7 providing stable and reliable web hosting solutions and services since 2001

  3. #3
    Join Date
    Mar 2008
    Posts
    1,717
    IMHO even on it's home turf (Linux) Apache comes out of the box performing like a sack of potatoes.

    Read some Apache tuning docs and I bet you can get much better performance out of it - for starters it's probably using Prefork and isn't there a win32-specific MPM?

    (Can you tell how often I use Windows servers?)
    I used to run the oldest commercial Mumble host.

  4. #4
    Join Date
    Jun 2009
    Posts
    79
    its set to Threadsperchild to unlimited (0), Namelookup to Off, .htaccess to None. How far does it need to be optimized. All other web servers perform out of the box like IIS 6.

  5. #5
    Join Date
    Jun 2006
    Location
    Europe
    Posts
    632
    seems you are running apache on windows server OS, and i've seen the same about apache on windows, it tends to give lower bandwidth for static file serving comparing to IIS6.

    to get better apache performance run it on linux.

    if your plan is to keep windows and serve static files only, you can use IIS6 for this, it will get you better performance for static comparing to windows-apache and linux-apache.

    if you are going to linux don't use apache, but instead nginx, lighttpd and similar for static hosting.

  6. #6
    Join Date
    Mar 2009
    Posts
    2,218
    Quote Originally Posted by Jatt5 View Post
    Here Apache at http://www.punjabistation.com:81/test/ and IIS 6.0 at http://www.punjabistation.com/test/ same files one getting around 400kbps and IIS 6 getting 768kbps. Does it Apache function slower then IIS 6 on windows server 2003. Strange Issue
    That's interesting. The server ought to be delivering files as fast as the network can go. What is the speed of the network?

    Speculating: IIS will default to a unit transmission size that works well with Windows Server TCP/IP defaults; Apache may be using a unit transmission size that's just a little bit too big for Windows Server TCP/IP defaults, and thus require two TCP/IP transmissions for IIS's one. In an environment where the network path is heavily loaded, this will cause Apache to transmit large files at about half the speed of IIS.

    As I said, that is speculation: I am just trying to think up an explanation for the observation.

    Searching on "Apache" and "tcp/ip parameters" turned up a post by WHT member "marknmel", posted back in April 2008 in a thread "tcp/ip tuning for better speed".

    The article referred to the following registry entries:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters]
    "MaxBufferedSendBytes"=dword:__VALUE__
    "MaxBytesPerSend"=dword:__VALUE__

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTPFilter\Parameters]
    "DefaultAppReadSize "=dword:__VALUE__

    The article contained a link, but unfortunately it no longer works.

    However, searching on the registry info found an item on the Microsoft site; the item is discussing another issue, but I figured you would have more confidence in instructions from Microsoft than from me.

    http://support.microsoft.com/default...b;en-us;906977

    "Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

    To resolve this issue, add the MaxBufferedSendBytes entry to the registry. To add the MaxBufferedSendBytes entry to the registry, follow these steps:

    1. Click Start, click Run, type Regedit, and then click OK.
    2. Locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters
    3. Right-click Parameters, point to New, and then click DWORD Value.
    4. Type MaxBufferedSendBytes, and then press ENTER.
    5. Right-click MaxBufferedSendBytes, and then click Modify.
    6. In the Value data box, type 65536, and then click OK.
    7. Quit Registry Editor.
    8. Click Start, click Run, type cmd, and then click OK.
    9. At the command prompt, type net stop http.
    10. At the command prompt, type iisreset /restart.

    Note To resolve this issue by using these steps, you must have Microsoft Windows Server 2003 Service Pack 1 installed."

  7. #7
    Join Date
    Jun 2009
    Posts
    79
    Quote Originally Posted by tim2718281 View Post
    That's interesting. The server ought to be delivering files as fast as the network can go. What is the speed of the network?

    Speculating: IIS will default to a unit transmission size that works well with Windows Server TCP/IP defaults; Apache may be using a unit transmission size that's just a little bit too big for Windows Server TCP/IP defaults, and thus require two TCP/IP transmissions for IIS's one. In an environment where the network path is heavily loaded, this will cause Apache to transmit large files at about half the speed of IIS.

    As I said, that is speculation: I am just trying to think up an explanation for the observation.

    Searching on "Apache" and "tcp/ip parameters" turned up a post by WHT member "marknmel", posted back in April 2008 in a thread "tcp/ip tuning for better speed".

    The article referred to the following registry entries:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters]
    "MaxBufferedSendBytes"=dword:__VALUE__
    "MaxBytesPerSend"=dword:__VALUE__

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTPFilter\Parameters]
    "DefaultAppReadSize "=dword:__VALUE__

    The article contained a link, but unfortunately it no longer works.

    However, searching on the registry info found an item on the Microsoft site; the item is discussing another issue, but I figured you would have more confidence in instructions from Microsoft than from me.

    http://support.microsoft.com/default...b;en-us;906977

    "Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

    To resolve this issue, add the MaxBufferedSendBytes entry to the registry. To add the MaxBufferedSendBytes entry to the registry, follow these steps:

    1. Click Start, click Run, type Regedit, and then click OK.
    2. Locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters
    3. Right-click Parameters, point to New, and then click DWORD Value.
    4. Type MaxBufferedSendBytes, and then press ENTER.
    5. Right-click MaxBufferedSendBytes, and then click Modify.
    6. In the Value data box, type 65536, and then click OK.
    7. Quit Registry Editor.
    8. Click Start, click Run, type cmd, and then click OK.
    9. At the command prompt, type net stop http.
    10. At the command prompt, type iisreset /restart.

    Note To resolve this issue by using these steps, you must have Microsoft Windows Server 2003 Service Pack 1 installed."
    The network is 100mbps. I never got over 16mbps upload speed in IIS 6 and 5mbps in apache = 400kbps to 500kbps transfer rate.

  8. #8
    Join Date
    May 2004
    Location
    Toronto, Canada
    Posts
    5,084
    IIS WILL outperform Apache on Windows. As others have said, if you wish to run Windows use IIS if you wish to run apache run it on linux.
    André Allen | E: aallen(a)linovus.ca
    Linovus Holdings Inc
    Shared Hosting, Reseller Hosting, VPS, Dedicated Servers & Public Cloud | USA, Canada & UK - 24x7x365 Support

  9. #9
    Join Date
    Mar 2009
    Posts
    2,218
    Quote Originally Posted by Jatt5 View Post
    The network is 100mbps. I never got over 16mbps upload speed in IIS 6 and 5mbps in apache = 400kbps to 500kbps transfer rate.
    1) There has to be some reason why both IIS and Apache are going so slowly. Can you try changing the MaxBufferedSendBytes parameter to 65536, restart the system, and assess the effect on both IIS and Apache?

    2) Does the Apache config have

    EnableSendfile Off

    If not, you should try it. If EnableSendfile is On, Apache does not send files itself, but employs operating system facilities to send them. Apache say that sometimes works badly.

  10. #10
    Join Date
    Jun 2009
    Posts
    79
    I think its a problem in theplanet.com network. I was getting full speed with IIS 6 like 2.5Mbps transfer rate 4 weeks ago. Now its around 600Kbps. I have done the registry trick not a single difference in speed. Also EnableSendfile is Off in Apache.

  11. #11
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    2,410
    Quote Originally Posted by Jatt5 View Post
    I think its a problem in theplanet.com network. I was getting full speed with IIS 6 like 2.5Mbps transfer rate 4 weeks ago. Now its around 600Kbps. I have done the registry trick not a single difference in speed. Also EnableSendfile is Off in Apache.
    It must be a setting, I highly doubt it is The Planet's network. Their network is pretty nice in my opinion.

  12. #12
    Join Date
    Jun 2009
    Posts
    79
    Quote Originally Posted by GCM View Post
    It must be a setting, I highly doubt it is The Planet's network. Their network is pretty nice in my opinion.
    So you think iis 6 auto changed the settings after it was fine like 4 weeks ago.

  13. #13
    Join Date
    Jun 2006
    Location
    Europe
    Posts
    632
    it could be network issues, but not neceseraly at theplanet DC, but instead at your ISP, or something inbetween.
    such as limited bandwidth per thread.

    did you try to get files from different locations?

  14. #14
    Join Date
    Jun 2009
    Posts
    79
    Me getting up to 3mbps transfer rate from all locations. Its an issue with theplanet that me getting only 600kbps.

  15. #15
    Join Date
    Jun 2009
    Posts
    79
    I Found Apache Do Excellent job on XP. Later versions of windows it does no good.

Similar Threads

  1. Zeus seems slower than Apache
    By tonkagunner in forum Hosting Security and Technology
    Replies: 2
    Last Post: 02-11-2005, 01:31 AM
  2. 2CO slower than ever
    By okihost in forum Running a Web Hosting Business
    Replies: 4
    Last Post: 02-17-2003, 02:36 PM
  3. wht slower slower....
    By pattox in forum Web Hosting Lounge
    Replies: 4
    Last Post: 02-02-2003, 01:07 AM
  4. XP is slower
    By Rewdog in forum Web Hosting Lounge
    Replies: 5
    Last Post: 11-02-2001, 12:21 AM
  5. WHT is much slower than before.
    By Domenico in forum WHT Announcements, Feedback and Questions
    Replies: 14
    Last Post: 09-17-2001, 05:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •