Results 1 to 4 of 4
  1. #1

    Remote Desktop Connection Problem through TS Gateway

    Hello all
    I rented out a Windows VPS a few days back and everything was fine. Now, I've joined an MBA course away from my hometown and am put up in a hostel within the college premises. The internet access here is through the institute's servers which means in order to connect remotely to the desktop I have to configure the "connection through terminal services gateway" within the remote desktop application in windows. But when I connect it gives the following error:

    "This computer can't connect to the remote computer because the certificate authority that generated the Terminal Services Gateway server's certificate is not valid."

    Anyone knows what the problem is? Any help would be really appreciated.


  2. #2
    bump! help please!

  3. #3
    Join Date
    May 2009

    I am suspecting you may not have configured your TS client with TS Gateway settings correctly. You can force the TS connection to use TS Gateway server, and you can test the connection from internal network as follows:

    1. Open the Remote Desktop Connection client. To open the Remote Desktop Connection client, click Start, point to All Programs, point to Accessories, and then click Remote Desktop Connection.

    2. In the Remote Desktop Connection dialog box, click Options to expand the dialog box and view settings.

    3. On the Advanced tab, in the Connect from anywhere area, click Settings.

    4. In the Gateway Server Settings dialog box, select the appropriate options:

    Use these TS Gateway server settings. You select this option and specify the name of the TS Gateway server that you want to connect to and the logon method to use for the connection. Note that when you specify a name for the TS Gateway server, you must use a fully qualified domain name (FQDN). as "" but without the https://www. prefix infront..

    Bypass TS Gateway server for local addresses. This option is selected by default. Please uncheck this checkbox.

    5. Click OK.

    6. On the General tab, type the name of the computer (terminal server or remote desktop) to which you want to connect remotely through TS Gateway (for example, you can specify CORPORATERESOURCE or an IP address).

    7. Click Connect.

    8. On the Enter your credentials page, select the user account that you want to use to log on remotely to the computer, and then enter the required credentials.

    9. Click Submit.

    7. Review the security warning, and then click Yes.

    10. On the Gateway server credentials page, select the user name that you want to use to log on to the TS Gateway server, and then enter the required credentials.

    11. Click Submit.

    12. After a few moments, the connection completes and a connection will be established through the TS Gateway server to the remote computer.

    If this works, I am pretty sure it will work from any Interent connections outside of your internal network.

    If this doesn't work, then you may not have right resource authorization policy in the TS Gateway server to allow connections using IP addresses.

    Either way we may need more detail on your setup.

  4. #4
    Join Date
    Mar 2009
    Santa Monica, CA
    1) Check the FQDN on cert and make sure you are connecting to TS GW using the exact same fqdn. If OK then,

    2) Maybe you are using the self-signed certificate at TS Gateway server? If yes, the client machine needs to trust the root certificate used for the signing the self-signed cerificate. You will need to install the root certificate on TS client machine.
    Last edited by Collabora; 06-17-2009 at 09:14 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts