Results 1 to 18 of 18
  1. #1

    Problems with Hostican

    Hey guys,
    I'm hoping to get some answers because i'm really confused.

    On Thursday, i've discovered that some of my clients on VPS (from Hostican) having some issues with databases, lost files and mail accounts. I've sent an email to Hostican and they told me that they are not able to find what happened.

    On Friday, i had a major mysql problem for all clients on that VPS. When i checked virtozzo to restart the VPS, i found out that Disk İnodes was between %90 - %100. They told me to delete some files and sent me a list with inodes usage/clients. I've terminated most used ones but it's still in high level.

    On Friday Night, they told me that they can't help me with any of my issues because i had an unpaid invoice. (a week before i sent an email to their billing deparment and told that i'll pay on 15th. They said ok no problem)

    Today, i paid my invoices and emailed them about my mysql problem & disk inodes problem. Here is the answer i got 3-4 hours later:


    Thanks for your reply.

    The problem is the amount of files you have hosted. If you have
    backups etc.. things that you dont need you will need to delete
    them to down the quota down.

    We would be glad to see if we can find some things that can be deleted
    but this mainly down to you to find and remove from the /public_html/
    folder and any backups that you may have.
    What should i do?
    My disk inode is at %94 right now and mysql is not working. Is it related?

    I can't call them because it cost tooo much from Turkey to USA.. In Hostican, i'm always quilty even when i'm right...

  2. #2
    Join Date
    Apr 2007
    Technically i dont see how the high disk usage will be effecting the opperation of mysql, if you ask them they should give you a temporary 10gb extra for a few hours to prove their claims.

    Have a look in /var/log and see if there is any large log files in there that can be removed as over time they can start to cause a problem if not deleted.

    Sounds more like a disk I/O bottleneck to me or low ram/cpu but don't really know without digging around.

    Also when you say loss of files and mail... there must be something removing these they don't just go, high disk usage would mean your unable to accept new mail or save files, it would not mean old ones are removed from the server. Just doesn't sound right to me.

    Let us know how it goes.
    - Buying up websites, side-projects and companies - PM Me! -

  3. #3
    Thank You Zanyhost
    I don't know what is happening with Hostican but when i send email to support at hostican i get mail delivery error...

    btw my disk space is at %46 and disk inodes is at %94. I'm not sure if extra disk space will work..

    Yeah you are right about old files... I don't know what is going on because i can't get any real answer and my clients want their money back

  4. #4
    An inode is like an index for each file. The problem is, that if you have a large number of files (typically many small files) each one will have an inode and then you will reach the inode limit which has been set by your provider (for Virtuozzo/OpenVZ). This is why you although you have disk space free you have few inodes left to create new files. I am not sure whether increasing diskspace will increase your inode allowance, I suppose you can ask Hostican?

    With Xen the number of inodes are typically proportional to your disk space, and generally much larger, but I digress. Good luck
    Exceptional VPS Hosting. With love, 6sync.

  5. #5
    ok i found why disk inode was high. It's because i've enabled backup. I've deleted the backup folder now its all green in virtozzo but mysql is still down!

    STILL Can't get any answers from hostican about mysql or anything.

  6. #6
    Hostican don't answer my questions so i try to solve on my own as a retarted vps owner (:
    ok here is what i get when i try to restart mysql:

    - Operation restart with the VPS(s) VEID123 service "mysql" is started

    - ERROR! MySQL PID file could not be found

    - Starting MySQL................................... ERROR!

    - Operation restart with the VPS(s) VEID123 service "mysql" is finished with errors: #703 Can not start/stop/restart service: service "mysql" status is not "running" after command "restart".

  7. #7

    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111)

  8. #8
    i found this in .err file.. maybe someone can help me to solve it... obviously hostican is in sleep mode...

    070602 10:35:26 mysqld started
    070602 10:35:26 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
    070602 10:35:26 [ERROR] Do you already have another mysqld server running on port: 3306 ?
    070602 10:35:26 [ERROR] Aborting

    070602 10:35:26 [Note] /usr/sbin/mysqld: Shutdown complete

    070602 10:35:26 mysqld ended

  9. #9
    WUHUUU! Hostican answered my chat request when i changed my name!!!! Can you believe this?

    Andy Cohen: limitations at your packages?
    You are now speaking with Jeff Lane of HostICan Sales.
    Jeff Lane: Hello, thank you for contacting HostICan sales
    Jeff Lane: please specify hosting package
    Andy Cohen: It's funny to see that when i change my name, someone finally answered me
    Andy Cohen: No one is answering my mails and chats
    Jeff Lane: could ypou specify your issue?
    Andy Cohen:
    Andy Cohen: Mysql is down for 3 days now... your support said that its because of disk inodes... i solved it but it is still down
    Andy Cohen: and no one is answering
    Jeff Lane: this is sales department and you should contact support:
    Andy Cohen: i did
    Andy Cohen: a lot of times
    Jeff Lane: i cant help you, since im not a tech
    Andy Cohen: at least can you tell them to do something... at least answering mails maybe
    Jeff Lane: please contact support and wait for their reply
    Jeff Lane: have a good day
    - Your party has left this session. -

  10. #10
    Join Date
    Apr 2007
    I suppose you have tried the obvious things like restart the vps?
    What control panel are you using? LxAdmin?
    - Buying up websites, side-projects and companies - PM Me! -

  11. #11
    yeah i tried that couple of times...
    virtozzo + whm + cpanel

  12. #12
    Join Date
    Mar 2006
    You have hit inodes limit and some DB has crashed. You need to take repair actions.

  13. #13
    Quote Originally Posted by WebHostDog View Post
    You have hit inodes limit and some DB has crashed. You need to take repair actions.
    Inodes is ok righ now but MySQL Service is not starting... You can check the errors i wrote on other posts..

  14. #14
    Join Date
    Mar 2006
    Yes when you hit the inodes limit MySQL is crashing and then you need to repair it before it can be started.

  15. #15
    Join Date
    Feb 2007

    I've taken a look into this, and it seems that you are hitting the inode limit. What you need to do is login to your SSH and find the files that you don't need and remove them.

    The Inode limit is 1.5 Million files, which seems is what you are hitting. If you woud like, we can see if we can do this for you. However, this would require you obtaining a management plan or paying for an administrator to resolve this for you.

    However, I would suggest that you try to resolve this yourself, as we don't want to delete files for you, in case they are important.

  16. #16
    I told that i've did this. Now disk inodes is green...
    Mysql still is not working and still no answer from support department.

    Also my topic at Hostican Forums. reffering to this one is deleted.

  17. #17
    On hostican's website, it says "24 Hours per Day - 365 Days per year" phone support but no one is answering!

  18. #18
    Ok.. i've checked .err file again... I saw that the failure is related with InnoDB...

    InnoDB: Database page corruption on disk or a failed
    InnoDB: file read of page 1.
    InnoDB: You may have to recover from a backup.
    InnoDB: It is also possible that your operating
    InnoDB: system has corrupted its own file cache
    InnoDB: and rebooting your computer removes the
    InnoDB: error.
    I googled a bit and saw a lot of comments like this:

    The printout shows that the page header differs from the page end. This is probably a problem in the OS/drivers/hardware, not a mysqld bug.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts