Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2001

    Question rpm & cpp problem


    stupid question with hopefully easy solution

    I tried to install cpp-3.2-7.i386.rpm via rpm, but it always ended up with the following error message:

    [[email protected]]# rpm -i cpp-3.2-7.i386.rpm
    error: cpp-3.2-7.i386.rpm: V3 DSA signature: BAD, key ID db42a60e
    error: cpp-3.2-7.i386.rpm cannot be installed
    I tried several mirrors, but none of the downloaded cpp RPMs would install (all ended with the same error (only the key ID changed)).

    Any ideas welcome

  2. #2
    Join Date
    Nov 2001
    Ann Arbor, MI
    From Red Hat Linux's docs:

    Starting with version 4.1 of RPM, the signature of a package is checked when installing or upgrading a package. If verifying the signature fails, you will see an error message such as:

    error: V3 DSA signature: BAD, key ID 0352860f

    If is it a new, header-only, signature, you will see an error message such as:

    error: Header V3 DSA signature: BAD, key ID 0352860f

    If you do not have the appropriate key installed to verify the signature, the message will contain NOKEY such as:

    warning: V3 DSA signature: NOKEY, key ID 0352860f
    -Mark Adams - Secure Michigan web hosting for your business.
    Only host still offering a full money back uptime guarantee and prorated refunds.
    Offering advanced server management and security incident response!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts