Results 1 to 6 of 6
  1. #1
    Join Date
    Nov 2001

    weird quota issue

    I've been running 2.4.9-31 kernel for awhile now..

    while i was running this kernel, i frequently used quota stuff

    meaning id add an account, run edquota -u username

    and set their soft limit, and their hard limit

    e.g if i want them to have a 6mb limit

    id set their soft limit to : 5000
    hard limit to : 6000

    so thats that....

    so last night i decided to upgrade to 2.4.19 kernel last night.

    in the menu config

    under File systems ---->
    i checked Quota support (put a asterik)

    compiled.... kernel booted fine.

    2.4.19 #1 Sun Nov 3 02:52:14 EST 2002 i686 unknown

    i just did adduser dooba
    edquota -u dooba

    i set soft limit to 5000
    hard limit to 6000

    then i su'ed to that username, and wgetted a 60mb file, and it didnt even stop me at all

    i'm confused. Is there something i missed?

    bottom line:

    ill add a user, set a quota for them, but it doesnt work...
    the user can go past their limit
    doesnt even say anything

    suron:/usr/src/linux# dmesg | grep quota
    VFS: Diskquotas version dquot_6.4.0 initialized

    Anyone have any ideas.

    If i can't get this to work then ill probably have to go back to 2.4.9 because having a working quota system is important.

  2. #2
    Join Date
    Oct 2002

    sorry for adding another question instead of answering to yours (I'm not skilled enough).

    I've never been able to understand how quotas work. webmin does not allow me to set quotas when creating a new user, I'm not even ask for quotas. do you use special modules or other stuff?

    thanks indeed!
    Real name: Tar Mkdir, consort of Dir Rar
    Working for: Imperial Klingon Vine Impex
    Note: No, we do not beam vine! Don't offend the Empire with such requests!

  3. #3
    Join Date
    Jun 2001

    time limits


    check if there are some time limits set for th quota's. IMHO the time limits control after which time the overquota message is printed and no more files are accepted.

    Take a look at the edquota manpage and there the -t switch.

    O. Schlag

  4. #4
    Join Date
    Nov 2001
    i ran edquota -t

    Grace period before enforcing soft limits for users:
    Time units may be: days, hours, minutes, or seconds
    Filesystem Block grace period Inode grace period
    /dev/hda3 0minutes 0minutes

    i didtn really understand that ^^
    so i tried changing it to

    1seconds 1seconds

    added a user
    set their quota to 5mb
    su'ed to that user
    it still let them go past the limit

    sigh, i don't know what to do.

  5. #5
    Join Date
    Nov 2001
    any ideas

  6. #6
    Join Date
    Nov 2001
    Ann Arbor, MI
    I agree that's odd.

    Try running a quotacheck and then test it.

    Then try booting your old kernel just to make sure it is a kernel problem.
    -Mark Adams - Secure Michigan web hosting for your business.
    Only host still offering a full money back uptime guarantee and prorated refunds.
    Offering advanced server management and security incident response!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts