Results 1 to 8 of 8
  1. #1

    Arrow HELP with PHP.INI

    I use a Linux RedHat 7.1 with plesk 2.0. I wanted to load php_gd.dll, how do I do that in Linux? In my windows pc I uncomment it and restart PHP and it worked, however it won't work on the Linux. Please help.

    ; Dynamic Extensions ;
    ; If you wish to have an extension loaded automaticly, use the following
    ; syntax:
    ; extension=modulename.extension
    ; For example, on Windows:
    ; extension=msql.dll
    ; ... or under UNIX:
    ; Note that it should be the name of the module only; no directory information
    ; needs to go here. Specify the location of the extension with the
    ; extension_dir directive above.

    ;Windows Extensions
    ;Note that MySQL and ODBC support is now built in, so no dll is needed for it.

  2. #2
    Join Date
    May 2001
    Dayton, Ohio
    Dynamic link libaries are only supported in windows.. To enable GD support in PHP your are going to need to recompile PHP with --with-gd=/path/to/gd
    -Mat Sumpter
    Director, Product Engagement
    Penton Media

  3. #3
    can you provide me with the steps?

  4. #4
    Join Date
    May 2001
    Dayton, Ohio
    Originally posted by certify
    can you provide me with the steps?
    Download the latest PHP from Currently 4.2.3..

    View a phpInfo() page on your server to get the configure line, it will look something like this:

    './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-swf=/usr/local/flash' '--enable-ftp' '--with-gd=../gd-1.8.4' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-imap=../imap-2001.BETA.SNAP-0105220031' '--with-mcrypt' '--with-ming=../ming-0.1.1' '--enable-magic-quotes' '--with-mysql' '--with-pear' '--enable-xslt' '--with-xslt-sablot' '--enable-safe-mode' '--enable-track-vars' '--with-ttf' '--with-zlib'

    Remove all ' ' so it looks like this:

    ./configure --with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-curl --with-swf=/usr/local/flash --enable-ftp --with-gd=../gd-1.8.4 --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-imap=../imap-2001.BETA.SNAP-0105220031 --with-mcrypt --with-ming=../ming-0.1.1 --enable-magic-quotes --with-mysql --with-pear --enable-xslt --with-xslt-sablot --enable-safe-mode --enable-track-vars --with-ttf --with-zlib

    Notice my bolded area above, thats where you apply it to your config line...

    Now untar your PHP tarball and change to the directory..

    Run your configure command with the needed features..

    After its done running do:


    And then:

    make install

    Restart apache, and check your phpInfo() to make sure you now have GD support

  5. #5
    './configure' '--with-apxs=/usr/local/psa/apache/bin/apxs' '--prefix=/usr/local/psa/apache' '--with-system-regex' '--with-config-file-path=/usr/local/psa/apache/conf' '--disable-debug' '--disable-pear' '--enable-sockets' '--enable-track-vars' '--without-gd' '--with-mysql=/usr/local/psa/mysql' '--with-iodbc=/usr/lib' '--with-imap=/usr/local/src/imap-2001a'

    ./configure --with-apxs=/usr/local/psa/apache/bin/apxs --prefix=/usr/local/psa/apache --with-system-regex --with-config- file-path=/usr/local/psa/apache/conf --disable-debug --disable-pear --enable-sockets --enable-track-vars --with-gd=../gd-1.8.4 --with-mysql=/usr/local/psa/mysql --with-iodbc=/usr/lib --with-imap=/usr/local/src/imap-2001a

    Ok I have copy and remove all the ' and now I should run the configure in the root?

  6. #6
    I understand now... but I got this error

    configure: error: Unable to find libgd.(a|so) anywhere under /usr/lib
    [[email protected] php-4.2.3]# locate libgd
    What should I do now?

  7. #7
    Getting nearer.

    [[email protected] libexec]# /usr/local/psa/apache/bin/apachectl start
    PHP Warning: Unable to load dynamic library './' - ./ cannot open shared object file: No such file or directory in Unknown on line 0
    /usr/local/psa/apache/bin/apachectl start: httpd started

  8. #8
    Ok the GD support is running but I still received the error when I start httpd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts