Results 1 to 4 of 4
  1. #1

    Angry Can't Modify my.cnf on My Dedicated Server!


    I have a dedicated server with RH 7.3,PHP, and MySQL. I believe RH and MySQL were RPM installs. I currently only have 100 connections available for MySQL and I sometimes run out, so I tried to modify my.cnf to allow for more. I can edit and save the file just fine, but after I restart MySQL for the changes to take effect, the my.cnf file is overwritten with the default settings! Does anyone know how I can get around this?



  2. #2
    Modify the file and then issue the following command:

    chattr +i /etc/my.cnf

  3. #3
    Thanks! It looks like that worked. Can I ask what that did?


  4. #4
    Join Date
    Sep 2002
    Dallas, TX
    The +i flag makes the file immutable. This means nothing can change it. Not even root. To change it again, you will have to remove the +i flag.

    chattr -i /etc/my.cnf
    justin 'at'
    Shared Unix Hosting

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts