Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2001

    Weird problem, help!


    I have a few servers that are:

    AMD Athlon XP 1900+
    1gb sd ram

    they have been running great.

    i'll untar a 300mb file, and it'll go fast, and be done within a few seconds.

    Then i have another one, that's AMD xp 2000+, 1gb DDR ram. It also has been running great, a b it faster than the xp 1900+

    Recently I bought a server that had the following specs:

    AMD Athlon XP 2200+ (1.8ghz)
    1gb DDR ram
    40gb hard drive

    my host just got it online last night, and emailed me the info.

    so today, i'm downloading proftpd, apache, php, installing my own stuff, ya konw, everything is going fine. apache compield fast, everything went smooth

    Then, i downloaded a 300mb file to the server, and ran

    tar xzf stock.tar.gz &

    because i didnt want to sit through and read what it was unzipping (i knew what it was unzipping)

    so while it was in the Backround, i went to go install proftpd, but i noticed the box being REALLY sluggish.

    I'd press enter, and it wouldnt do it until like 2 secs later.

    Or i'd do wget ftp://balh/blah/blah/proftpd.tar.gz

    and it'd be REALLY slow, and i'm not talking network wise. you could tell this was a problem w/ the machine.

    i went to go login the box twice, and boy was it slow.

    took forever just to get to the root prompt (Again, felt like it was a machine prob)

    i ran 'w' and saw the load average being 4. something (i think 4.40)

    i was thinking WOW, 4.40 load just to untar a 300mb file ??

    Keep in mind, ive untarred this SAME 300mb file on my other xp servers, and the load was alwyas under 1.00 (more like 0.63)

    i just could not understnad why the box was behaving this way. it was almost as if it was just struggling..

    so i ran killall -9 tar gzip

    manually unzipped it

    tar xzvf stock.tar.gz

    then i checked the other window (where i was logged in twice)
    and again, the load sky rocketed

    i was puzzled.

    i ran top, and these are some of the things i saw (i tried to capture it before it disappeared)

    Can you believe that?? I have untarred huge files on my other xp's, and watched top while i did it, and kswap never uses 99% cpu??

    neither does kjournald

    something is seroiusly wrong. NONE of my xp's behave like this one does

    Does anyone have any idea why this is happening? Any info would be appreciated!

    bones:~# uname -a
    Linux bones 2.4.18-3 #1 Thu Apr 18 07:32:41 EDT 2002 i686 unknown

    bones:~# cat /proc/cpuinfo
    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 6
    model : 8
    model name : AMD Athlon(TM) XP 2200+
    stepping : 0
    cpu MHz : 1795.393
    cache size : 256 KB
    fdiv_bug : no
    hlt_bug : no
    f00f_bug : no
    coma_bug : no
    fpu : yes
    fpu_exception : yes
    cpuid level : 1
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
    bogomips : 3578.26


    bones:~# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/hda3 35G 1.5G 31G 5% /
    /dev/hda1 45M 8.6M 34M 20% /boot
    none 500M 0 499M 0% /dev/shm

    bones:~# free -m
    total used free shared buffers cached
    Mem: 999 339 659 0 10 310
    -/+ buffers/cache: 19 980
    Swap: 2047 0 2047

    dmesg can be found here!
    Last edited by clocker1996; 10-23-2002 at 04:39 PM.

  2. #2
    Join Date
    Nov 2001

  3. #3
    Join Date
    Nov 2001
    Hmmmm... Looks like DMA was off. Usually it's on by default, I guess for some reason it wasn't. Well anyhow, i ran hdparm -d1 /dev/hda

    and now the problems are gone.

    Well for anyone who took the time to read the thread, thanks, and sorry i wasted your time!

    Mod please delete this thread, or close it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts