Results 1 to 6 of 6
  1. #1

    * Hello - I need WHM help NOW!

    Realy needing some help right now. I have not set up resellers before in WHM and I have set up a reseller, but everytime he creates an account it is IP based not name based. What have I done wrong?
    Last edited by freakysid; 10-21-2002 at 09:53 AM.

  2. #2
    Update - at this stage it seems that WHM is only using one IP address for shared IP virtual hosts (name based virtual hosts).

  3. #3
    OK - well, I got it sorted. but I had to go into httpd.conf and fix things up myself. What I don't understand is this. To set up an account to be a reseller account one has to assign an IP to the account right? It has to be an IP based virtual host. But then this uses up one of your IPs for just that account. Can one configure things so that the IP you assign to the reseller account is also the IP which is shared by all that reseller's accounts???????

  4. #4
    Join Date
    Oct 2002
    yeah sure..the IP alloted for the reseller could be used by his resold accounts..

    you can disable the dedicated IPs being alloted by reseller to his accounts at the "Please select which features $reseller should have access to:" section in the "Edit Reseller Privileges/Nameservers" section...

  5. #5
    Hi - this is really driving me and my poor customer crazy.

    1) Under the "Edit Reseller Privelages/Nameservers" section I have the dedicated IP option disabled.

    2) Under the "Manage Reseller Ip Delegation" section I have

    "Restrict ips reseller_name can use for accounts"
    and specified one IP let's say it is:


    However in the list, next to that IP address it says:
    (Already used by

    Where "" is one of the resellers other accounts. I must admit I did go into httpd.conf and fiddle with it to make this virtual host to make it namebased. As I think it was setup originally as IP based.

    3) Under "Manage Reseller Main Shared/Ipless Ip"

    I have specified the same IP XXX.XXX.XXX.111

    Now when reseller goes to create a new account, the message comes back:

    Using Delegated Ips List!
    Unable to find an ip address
    Account Creation Complete

    but of course - no account.

  6. #6
    Join Date
    Oct 2002

    This seems to be a bit complicated.

    Try this.

    1.Comment all the VirtualHost entries in httpd.conf for that IP and keep only the main account, restart apache.

    2.Make sure that the main account is alloted the dedicated IP in WHM.

    3.Try adding a new account from whm. When it is completed, copy the newly added virtualhost entry and recreate the previously commented ones with required changes in the newly added one.

    Hope this will help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts