Results 1 to 7 of 7

Thread: WHM Woes

  1. #1
    Join Date
    Sep 2002
    Location
    Scotland
    Posts
    421

    * WHM Woes

    Hi,

    We jsut got our new server online.

    First thing I did was go into WHM which the host had setup. Now intially I thought o make an account for our site. WE host a few other sites fro free, but just one main site.

    It kept gving me the error.Sorry, that domain is already setup (remove it from httpd.conf?

    So then I looked at host name, they had called it warofthering.net. So I figured this was problem as it says do not use name used in any account. So changed it to blah.hostname.com as recommended by whm.

    Meantime the host had made a manual entry for the site in apache. So I had them remove this and tried again.

    Still got Sorry, that domain is already setup (remove it from httpd.conf?

    So they searched some more and found other entries that whm makes when a domain is added. They said they cleared all they could find. But still gettting this error. I can setup account in other names but not with our site as domain.

    Can anyone help. WE want to get moving asap. If we have them add the site to apache manually then we will not be able to use Cpanel as WHM will have no account for it...........

    Am I being real dumb here or.....

    Thanks folks.

    James

  2. #2
    Join Date
    Jan 2002
    Location
    Scotland, UK
    Posts
    2,687
    Check all the zone files (if any) for the domain are removed.
    Chris Adams - CEO - Rochen Ltd. - chris (at) rochen (dot) com

    Now offering both US & UK premium business hosting, reseller hosting and managed virtualized services.
    rochen.com | rochen.co.uk | blog.rochen.com | forums.rochen.com | Twitter: @rochenhost

  3. #3
    Join Date
    Sep 2002
    Location
    Scotland
    Posts
    421
    Thank, but I have checked in whm, and only one zone left, the entries for the hostname, which is the renamed one...

    There are no accounts setup either.

    Any other ideas?

  4. #4
    Join Date
    May 2001
    Posts
    682
    It sounds like they are possibly removing the entry from a duplicate httpd.conf.

    AFAIK httpd.conf is the only file that WHM looks at when setting up an account. But if the user was setup manually before the account was setup, the user will have to be removed, or when setting up your domain, force another username in the blank instead of what WHM suggests.

  5. #5
    It seems that your provider set up yourdomain.com as your server hostname. Now you need to change your server hostname to something like sub.yourdomain.com (in WHM) and then open your httpd.conf and remove the VirtualHost entry for yourdomain.com (if it has), leave VirtualHost entry for sub.yourdomain.com as it is. After that you can restart Apache and setup yourdomain.com
    AceWebHosting.Com
    Cheap Web Hosting - Multiple Domain Hosting - Reseller Hosting - Virtual Private Server

  6. #6
    Originally posted by rastoma
    AFAIK httpd.conf is the only file that WHM looks at when setting up an account. But if the user was setup manually before the account was setup, the user will have to be removed, or when setting up your domain, force another username in the blank instead of what WHM suggests.
    I think if the user already exists, WHM will return an error telling you that the username is not availble.
    AceWebHosting.Com
    Cheap Web Hosting - Multiple Domain Hosting - Reseller Hosting - Virtual Private Server

  7. #7
    Join Date
    Sep 2002
    Location
    Scotland
    Posts
    421
    Thanks folks. You are right Networksdata it returns a that domain is already.......please remove from httpd.conf.

    Turned out there was a reference to the domain lurking on that file. Even though we had changed the hostname in httpd.conf there was still a line with servername=domain.net.

    Once that was removed it let us make the account.

    SO thanks for all your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •