Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2002
    Location
    Barcelona (Spain)
    Posts
    75

    Cannot resolve IP with www.mydomain.com but no problem with mydomain.com (!)

    Hi all,

    Do you know the reason of connecting to a page if sent as mydomain.com but no chance if connecting as www.mydomain.com ?

    I have requested my client (I run a small reseller) to try by http://ip_number/~user_name/ and then this test works fine.

    My explanation has been "the resolving of an IP is a matter of your ISP. They should obtain the IP either sending a domain name with or without www. When you directly send the IP you bypass the server IP resolver. My server only understands of IP figures. Therefore this has nothing to do with my server".

    I ask, am I right? or there is another possible reason for that missfunction of my client domain? I have to point out that this problem is not stable... sometimes everything works fine, sometimes it does not.

    I will appreciate your thoughts and advice.

    Thanks !!

  2. #2
    Join Date
    Oct 2002
    Posts
    250
    Could be a few things.

    Apache: Look at your httpd.conf and make sure you have the proper aliases specified.

    DNS: use nslookup or dig and see if the A/CNAME records are setup properly.

    if domain.com has resolved, www.domain.com should be resolved as well.

    Bob

  3. #3
    Join Date
    Jun 2002
    Location
    Barcelona (Spain)
    Posts
    75
    Thank you, Bob, for your advice.
    Pere
    www.casti2001.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •