Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2002
    Posts
    281

    please help: proftpd and webmin

    hello

    i did just install proftpd on my redhat box (rpm version/webmin) but I have a really stupid problem.

    1) I add a new account
    2) I click on aply changes
    3) nothing works

    reason: when I click APPLY CHANGES the proftpd server does not restart (it doesnt stop as well)... it seems it does nothing. Only when I manually kill proftpd (the process) and then start it again... the new accoutn works.

    I've tried to understand whats wrong in my module config... but I did not find the error. Could you please help me?

    Here is what I have in the module config of proftpd in webmin:

    Path to ProFTPD config file: /usr/local/etc/proftpd.conf
    Path to ProFTPD executable: /usr/local/sbin/proftpd
    Path to ProFTPD PID file: /usr/local/var/proftpd.pid
    Path to ftpusers file: /etc/ftpusers
    Command to start ProFTPD: AUTOMATIC

    thanks indeed in advance!
    Real name: Tar Mkdir, consort of Dir Rar
    Working for: Imperial Klingon Vine Impex
    Note: No, we do not beam vine! Don't offend the Empire with such requests!

  2. #2
    Join Date
    Sep 2002
    Location
    Mansfield
    Posts
    314
    First, is the path to the PID file correct?
    Login, look at it, then check it against the actual running PID.

    Then, find the rc script to start proftpd and put it into webmin manually.

    Webmin has been rock solid for a long time, but it usually requires a few minor tweaks like that. FreeBSD can be really bad because it uses Linux pathing most of the time. <insert holy war here>
    GUI admin tools have no honor. It is a good day to vi.

  3. #3
    Join Date
    Oct 2002
    Posts
    281
    Hello,

    ouch you are right! the pids do not match. the pidfile contains a number.... webmin says proftpd runs with another process number.

    what shall I do? can it be that the pidfile contains a wrong value?

    thanks indeed,
    a real alien
    Real name: Tar Mkdir, consort of Dir Rar
    Working for: Imperial Klingon Vine Impex
    Note: No, we do not beam vine! Don't offend the Empire with such requests!

  4. #4
    Join Date
    Sep 2002
    Location
    Mansfield
    Posts
    314
    stop & start proftpd manually - kill <PID number>

    /path/to/startup/script start (anyone else - jump in, I don't where RH puts things)

    see if your changes worked.

    check to see what the pid is now in the pidfile and the process table - do they match ?
    GUI admin tools have no honor. It is a good day to vi.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •