Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2002
    Location
    Hawaii
    Posts
    13

    Question ftp logon time ~ 40 seconds Linux7.3

    Just started dedicated hosting on linux7.3 box, and also built another that i have running at home. They both do the same thing loggin in ftp clients - which is to wait 30-40 seconds between connect time and the next prompt. Applies to command line as well as ftp client programs. This is probably an easy one, but like i said, newbie at work!

  2. #2
    Join Date
    Apr 2002
    Location
    USA
    Posts
    5,779
    Add your main name server IPs and server IP to the resolv.conf file.

    You can also turn off reverse DNS lookups and indent lookups in your proftpd.conf file.

    Open /etc/proftpd.conf and find this line:

    DefaultRoot ~ !wheel

    Below it add:

    UseReverseDNS off
    IdentLookups off
    TimeoutNoTransfer 900
    TimeoutIdle 900
    Last edited by The3bl; 10-08-2002 at 06:48 PM.

  3. #3
    Join Date
    Sep 2002
    Location
    Hawaii
    Posts
    13
    I should have said. using wuftp - the same idea, then?

    Thanks, rp

  4. #4
    Join Date
    Jun 2002
    Location
    sydney.au
    Posts
    246
    Yeah. When a Unix (or Linux) networking program sits there for thirty seconds and then suddenly starts working every time it's a safe bet that it's trying to do a reverse DNS lookup and failing.

    Your options:
    Get DNS working properly so the machines can find each other.
    Just stick the relevant IPs in /etc/hosts.
    Hack /etc/resolv.conf to only wait a couple of seconds instead of 30. (Not recommended.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •