Results 1 to 1 of 1
  1. #1
    Join Date
    Jul 2002
    Kolding, Denmark

    * RH7.1 + MySQL + GLIBC-update = Problem!

    Hello All

    Just a piece of information:

    We run our databases on vservers on top of a RH7.1 and today I ran into a pretty nasty problem:

    After upgrading to the latest RH7.1 glibc (glibc-2.2.4-30) with up2date I was unable to restart the mysql service. This goes for mysql-3.23.36-1 as well as 4.0.1-alpha - the first complains about other mysql servers running on the same IP while the last keeps on reporting hung processes and restarting them.

    The services ran fine right after the upgrade but when I tried restarting them later things went haywire. Another vserver with mysql-3.23.36-1 had no problems but this server wasn't carrying any load at all.

    Bottom linie: Be careful when upgrading glibc on RH7.1 production servers - there may be a problem that doesn't show in a lightly loaded test-environment.

    Downgrading glibc, glibc-common and glibc-devel to glibc-2.2.4-29 took care of the problem but I sure had some interesting minutes there...
    Last edited by goldenplanet; 10-07-2002 at 10:40 AM.
    Best regards,

    Anders C. Madsen
    Golden Planet Support -

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts