Results 1 to 7 of 7
  1. #1

    Exclamation Can't Restart or Start Apache Anymore!!!

    System: RH7.3 w/ Apache

    I just edited my httpd.conf file to add a subdomain of I then restarted apache and the subdomain page wasn't working... just a blank screen, but all my other pages were working just fine. I only typed apachectl restart so I though hey, let me stop and start httpd, so I typed apachectl stop and then apachectl start and it said: "httpd started"

    When I tried to access the site, nothing came up. So I tried to stop httpd and I got this:

    "httpd (no pid file) not running"

    I then tried to remove the virtual host lines I added, but no luck. Something else seems to be causing this problem. I checked my httpd error_log file and this was the line that would come up:

    "[crit] (98)Address already in use: make_sock: could not bind to port 443"

    I then commented out all SSL lines, since I don't use them. Now I get this message:

    "[crit] (98)Address already in use: make_sock: could not bind to port 66"

    My ip address is so I think that's where that is coming from, but why? Is this reall the problem or might it be something else.

    Thanks for any help,

    Last edited by LancerForums; 10-07-2002 at 09:32 AM.

  2. #2
    I just checked httpd's status and it says:

    "httpd dead but subsys locked"

    Thought that may add some more insight.


  3. #3
    Restarted apache and it works now, but I'm back to the blank subdomain pages:

    Here's the subdomain link:

    and here's the virtualhost in httpd.conf:

        ServerAdmin [email protected]
        DocumentRoot /abs/path/to/myevolutionm
        LogLevel error
        ErrorLog logs/
        CustomLog logs/ combined
    any ideas?



  4. #4
    Join Date
    Jul 2002
    Works for me
    Unlimited Space & Bandwidth
    Providing hosting since 17/99/3003

  5. #5
    Join Date
    Oct 2001
    san diego
    is there an index page in your html directory?

  6. #6
    Join Date
    Sep 2002
    check the process table to see if it is running or not

    ps -aux | grep http

    then apachectl stop

    apachectl configtest
    httpd -T and -t to check directories and syntax

    then apachectl start or startssl, depending on what you're running.

    httpd -T amd -t tell lots of good info.

    Vhost entry looks fine assuming the logs path is defined. No cgi-bin?
    GUI admin tools have no honor. It is a good day to vi.

  7. #7
    Join Date
    Dec 2001
    Franklin, TN, USA
    works fo me also
    Linux. Problems Solved. | Built for the Hosting Industry
    Server Management. Helpdesk Management. Business Management.
    ( AcuNett, Est. 15 Years, RateLobby 5 Stars )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts