Results 1 to 9 of 9
  1. #1

    CGI-BIN folder does not work

    Hello,

    I recently deleted cgi-bin folder and re-created it but after that my cgi scripts don't work, all the chmods are correct and I also tried using my scripts at another account and worked fine, what could be problems here? What I have to do?

    Thanks in advance.

  2. #2
    The cgi-bin folder/directory also need to be chmod 755 Did you chmod the folder/directory after creating it ?
    WHO AM I? CLICK HERE!

  3. #3
    Yes, but it still doesn't work

  4. #4
    Join Date
    May 2001
    Location
    Prince Edward Island
    Posts
    964
    [self edit] DumbA$$ answer, so i removed it [/self edit]
    [url]I got nothing/url]

    For clarity's sake, don't use "<ip address of hostname>" use the ACTUAL 32-bit numeric IP address of the machine.

  5. #5
    When I looked into error log I saw: File does not exist: /home/dummy/public_html/500.shtml. I use Cpanel so what should I do?

  6. #6
    If you are using CPanel, you could access the trash folder to restore the original cgi-bin folder and see if it works.
    WHO AM I? CLICK HERE!

  7. #7
    Thanks all. I just remove the .htaccess file and my scripts work again.

  8. #8
    Join Date
    Aug 2000
    Location
    Tacoma, Washington
    Posts
    9,576
    when things act odd, it's a very wise decision to look for a .htaccess file. I don't know how much of my life I could have used for better things if I'd developed an urge to hunt .htaccess earlier

    Greg Moore
    Former Webhost... now, just a guy.

  9. #9
    Originally posted by InternetSon
    Thanks all. I just remove the .htaccess file and my scripts work again.
    For future reference, it was trying to serve up a 500 error page, which means there was an internal server error it was trying to report. This time that error was apparently caused by invalid directives in your .htaccess file, but it could also have mean there was a problem with the CGI scripts themselves (such as uploading them in binary instead of ASCII mode if there were Perl or Python scripts and not compiled). However, that wasn't the case this time. I would suggest you provide a little more information about how it wasn't working too, so you can get answers faster next time. Glad it worked though.
    Robert McGregor
    URL: http://www.2host.com
    Email: robertm@(nospam)2host.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •