Results 1 to 8 of 8
  1. #1
    Join Date
    Aug 2002
    Location
    PA
    Posts
    32

    Help with safe mode/open_base_dir

    I am tryingto get a script installed on a plesk server that has
    safe mode and open_basedir limitations. The script uploads images to a mySql database but the open_basedir will not allow
    the script to write and read from the php tmp directory.
    Does anyone know a way around this or a way to redirect
    to a tmp folder within the allowed space? The host was not
    any help.

    Any suggestions appreciated!

    Thanks,
    Tim

  2. #2
    Join Date
    May 2002
    Location
    England
    Posts
    21
    Easy peasy, in your domain directory on your server (/usr/local/psa/home/vhosts/domain.com) you will find a directory called conf . In that place this file:
    (file is named vhost.conf or vhosts.conf for SSL sites)
    <Directory /usr/local/psa/home/vhosts/domain.com/httpdocs>
    php_admin_value safe_mode 0
    php_admin_value open_basedir "/usr/local/psa/home/vhosts/domain.com/httpdocs/:/"
    </Directory>

    Replace anything which says "domain.com" with your domain. That should sort you out.

    James

  3. #3
    Join Date
    Aug 2002
    Location
    PA
    Posts
    32
    There are no files visible in the conf folder and I am unable to
    add any. I just get a 550 permissions error. I also can
    not add any folders in the base domain directory
    either. I guess I am not going to be able to do anything
    since the host has everything restricted.
    Thanks for trying though.

    Tim
    Tim S

  4. #4
    Join Date
    May 2002
    Posts
    441
    You probabally need to do this in ssh while logged in as root.

  5. #5
    Join Date
    Aug 2002
    Location
    PA
    Posts
    32
    I can not. I am trying to help a guy that bought a script
    get it installed. He uses a host and does not have root
    access. I had him contact the host but they refuse to help
    in any way. Their only reply was basically yes it is restricted
    to bad for you.

    Thanks anyway.
    Tim S

  6. #6
    Change the host.

  7. #7
    Join Date
    May 2002
    Location
    England
    Posts
    21
    Hi Tim,
    Sounds like your host really doesn't have your custom in mind. I thought you had root access to your server and hence why I suggested putting that script in. I didn't realise you were the customer of another host.

    If you are looking for a host that will allow PHP safe mode to be turned off for your domain then I can recommend www.22host.com . Althought I'm sure this is probably against the rules. Who knows. If it is then can an admin please delete this post.

    James

  8. #8
    Join Date
    Aug 2002
    Location
    PA
    Posts
    32
    Thanks for the suggestions. I was just trying to help a customer that bought the script from me get it installed. I also suggested to him that he find a different host.

    Thanks,
    Tim
    Tim S

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •