Results 1 to 8 of 8
  1. #1

    My site: MazdaWorld.org...

    I kept it simple and light on graphics because of bandwith issues (this site gets 10 new members a day now, been up for 3 weeks or so).

    It works in every browser, at every resolution (took a lot of time to do that). Netscape 4, 6. IE (all versions). Mozilla. Opera. That's what I've tested (so if you have a Mac, I'd appreciate it..).

    Anyways, let me know what you think.

    Thanks a bunch

    My Site
    Last edited by Hercules; 09-18-2002 at 11:25 AM.

  2. #2
    Join Date
    Sep 2002
    Posts
    57
    The site looks simple and conventional. It is fast to load. I checked your forum. It looks good. There is no link to go back to the home page.

  3. #3
    I thought it is a transport company's site The name resembles it(Joke)
    Your site is looking good with good design. I like it.

  4. #4
    Join Date
    Sep 2002
    Location
    Minnesota
    Posts
    65
    If you're asking for a review, it's best to put a link in your post so people can get to your site without having to type it in themselves.

    It does load fast, but personally I think it's a little too light on graphics. You can have a few graphics on a page that won't slow it down that much, just compress them. I need more visual impact, if it's a site about Mazda's, picture a Mazda to emphasize it.

    Also, I'm on a Mac using IE 5.1.5. If you want to know what it looks like on mine, check out the screenshot.
    Attached Thumbnails Attached Thumbnails screenshot.gif  

  5. #5
    Originally posted by AboveCenter
    If you're asking for a review, it's best to put a link in your post so people can get to your site without having to type it in themselves.

    It does load fast, but personally I think it's a little too light on graphics. You can have a few graphics on a page that won't slow it down that much, just compress them. I need more visual impact, if it's a site about Mazda's, picture a Mazda to emphasize it.

    Also, I'm on a Mac using IE 5.1.5. If you want to know what it looks like on mine, check out the screenshot.
    Thanks for that

    I updated the post so the link is in it as well

  6. #6
    Is there any sory of TM issue here? I went to www.MazdaWorld.com and that site seemed to redirect to www.MazdaUsa.com when you clicked on certain links. I would just be careful with the sites, since Mazda is TM.
    Domain Software, LLC.

  7. #7
    Join Date
    Mar 2002
    Posts
    135
    I think your site lacks eye appeal. It loaded very quickly which is always good, but it lacks imagery/graphics. A little bit, just enough the take the "blah look" out.

  8. #8
    Originally posted by punaboy
    I think your site lacks eye appeal. It loaded very quickly which is always good, but it lacks imagery/graphics. A little bit, just enough the take the "blah look" out.
    Soon I'm going to run articles and with those they will have pictures... so I'm not worried about the blandness of the site just yet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •