Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2002
    Dallas/Plano, TX

    Help!!! Too Weird!!!


    I hope this is not the wrong forum for this but I KNOW that the collective genius here could solve all the world's problems if properly directed so mine should be easy!

    I have a site hosted with Shag Host ( and I can't figure out the problem and neither can Brett. There are two links on the pages that are having problems; "Contract" & "Policies". Each of these are simple .RTF documents. When I click on either of these I'm presented with a 2"x3" window titled "Enter Network Password". It says "Please enter your authentication information" and is asking for a "User Name" and a "Password" I guess to "view" the document? In any event neither documents are password protected, they were not created on a network and most people experiencing the same thing are not on networks. In addition, if you click on the "Cancel" button in the window, the document is presented just fine. I have also attached a screen grab of the Authentication Box if that will help any.

    Here are some things I've done to try and isolate the problem and the results I got:

    1) Created another dummy .RTF file using WordPad called doc.rtf, placed it in the "Contract" directory, changed the Index file so it would access doc.rtf instead of contract.rtf, tried to access it and had the same password problem. So it's not something in the contract.rtf file itself.

    2) Created a dummy ".TXT" file using WordPad called contract.txt, placed it in the "Contract" directory, changed the Index file so it would access contract.txt instead of contract.rtf, tried to access it and had NO "PASSWORD" PROBLEM. So this means that, for some reason, their system does "NOT" like .RTF files!

    3) Placed a copy of the contract.rtf file into the "Calendar" directory, changed the Index file so it would access contract.rtf instead of calendar.htm, tried to access it and had the same password problem. So it doesn't care what "directory" the .RTF file is in at least within the website allotted space.

    I had this site hosted at #%@*&@$*&"CYBERWINGS"@)&@%(*&@$ and never had a problem with the password authentication popping up there until one day the whole site mysteriously disappeared. In any event, Cyberwings had the FrontPage extensions turned off and I believe ShagHost has them on, if that makes any difference.

    Very Weird!! Not sure what to try next but I can't use the site like this. I've had several people try to access the contract and some have been presented with the password box BUT some haven't. They also click on "Cancel", the box disappears and the contract comes up just fine.

    If anyone has any ideas that might solve this I would be more than glad to purchase you a trip for two around the world, a new automobile each and every year until you die and last but not least, your own private 100 foot yacht..... ;-)
    Attached Thumbnails Attached Thumbnails error.jpg  

  2. #2
    Join Date
    Jul 2001
    Troy, Missouri USA
    They both open up in MS-Word for me!

  3. #3

    Just a suggestion

    You might try a different approach; when I tried your site, my browser tried to save the file as a download, so here's at least 3 different approaches to dealing with this, and you need a consistent approach that works on all browsers.

    This likely arises because the httpd.conf file doesn't know how to handle an RTF file (the AddHandler directive might be able to tell it, but I'm not sure Apache could display it properly).

    So, why don't you convert the RTF file to an HTML page, OR, make it a PDF file, which would preserve the existing formatting you have, and most users know how to handle PDF files.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts