Results 1 to 6 of 6
  1. #1

    Angry Ever since installing patch .htaccess won't werk! RAQ 4r

    installed RaQ4-All-Security Release 2.0.1-15417 now httpd won't recognize .htaccess files... give page cannot be displayed error... anyone having the same problem or know how to fix it? And I have already tried recreating the .htaccess and password files... still doesn't work... mainly worried about FP users since it uses .htaccess for auth.

    Thanks in Advance.

  2. #2
    Join Date
    Oct 2001
    Look for AllowOverride None in your config files for apache, and remove it (only for /home/sites not for any other dir)
    Avi Brender
    Reliable Web Hosting by Elite Hosts, Inc
    CPANEL Reseller Hosting - Fantastico - Rvskins - ClientExec

  3. #3
    thanks but ive tried everything as far as configuration goes. AllowOverride All is what I have for /home/sites... in access.conf... Ive also tried to put it in httpd.conf still it does not work... I am assuming that the patch screwed up the httpd executable somehow... there are others on the Sun Cobalt support forum with these same problems... Im trying to spread this around to see if anyone else is having these problems or did and fixed it.


  4. #4
    I am having the same problem. When ever I try to access a page protected with htaccess I get a page can't be found. I have checked every thing in the confg file and it still does not work.
    Did anybody ever come up with a solution to this problem.

  5. #5
    Join Date
    Nov 2002
    I have this patch (and all Cobalt patches) on my RaQ 4, and .htaccess files work just fine.

    Here's the contents of mine:

    # in the directory listed in the AuthUserFile,
    # do the following command:
    # htpasswd -cm .htpasswd username
    # The -c means create a new file
    # the -m means store MD5 hashes of the
    # password
    # If you need to add another user, do the
    # same command but leave out the "-c":
    # htpasswd -m .htpasswd username

    AuthPAM_Enabled off
    AuthUserFile /home/sites/site2/.htpasswd
    AuthName "Secure Directory"
    AuthType Basic
    Order allow,deny
    Allow from all
    <Limit GET POST>
    require valid-user

    The 'AuthPAM_Enabled off' is one that a lot of people forget to put in.

    Since you mentioned FrontPage, that might be the source of the problem. I know at some point, file ownerships were changed to 'nobody' for security reasons. I don't use or know anything about FP, so I can't comment on that. But doublecheck ownership of your FP files, .htaccess files, etc. as that may be the cause. - LAMP and LAMP+SSL HowTo - Cobalt FAQs and HowTos

  6. #6
    Thank you for the reply. But this has nothing to do with how I create htaccess files. The reason I say this is even the htaccess files that webalizer creates give the same error which is "file can not be found". Also it does not mater what type of htaccess file it is if you do one to redirect the error messages you get the same error "page can't be found" on sites that have Front Page. Front Page does not work at all.
    This problem is beyond the simple problem cased by configuration or how you create a htaccess file for password protection.
    I have other RAQ4 server that every thing works just fine it just this one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts