Hi, i have a server from fdc Athlon Xp 1800+, Asus mainboard with KL133 chipset, 512 Mb RAM, 60gb IBM hard disk, Redhat 7.3

At the beggining i had data corruption especially when i downloaded or read rar files. For example if i tested a bunch of rars, every single time, it showed me that different files were corrupted, even if they were not. This means that the disk reads the files corrupted.

At the beggining i tried to play with the hdparm parameters, and found that when i disabled the UDMA everything was fine. Of course i couldnt continue running my server with 2,2Mb/sec from the hard disk, and tried to find a solution.

I complied 2.4.19 kernel with my chipset's support, and after that i tried the beta 2.5.32. With the beta everything worked better, and i found that when disabling with hdparm the read ahead (hdparm -a0 /dev/hda) the disk is working fine. No corruption, good speed (about 20 Mb/sec, and 150Mb/sec from buffer).

I worked fine for 1 day, and suddenly i see that i have again corruption, and this time when i do a hdparm -Tt /dev/hda to test speeds, it is saying, 19Mb/sec (good) and 28Mb/sec from buffer which is really bad. After that its saying. Hmm, strange results, maybe there is a lack of memory to do a proper test!!!

Can anyone help me eith this (corruption?) Thanks