Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2005
    Posts
    483

    Error during "Yum update"

    Hello I'm trying to run "Yum update" but it ends up with error. Here is the full log:

    Code:
     yum update
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
     * rpmforge: ftp-stud.fht-esslingen.de
     * base: mirrors.service.softlayer.com
     * updates: mirrors.service.softlayer.com
     * addons: mirrors.service.softlayer.com
     * extras: mirrors.service.softlayer.com
    Excluding Packages in global exclude list
    Finished
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package perl-BSD-Resource.x86_64 0:1.2901-1.el5.rf set to be updated
    ---> Package iftop.x86_64 0:0.17-1.el5.rf set to be updated
    ---> Package perl-IO-Socket-SSL.noarch 0:1.13-1.el5.rf set to be updated
    ---> Package perl-HTML-Parser.x86_64 0:3.56-1.el5.rf set to be updated
    ---> Package perl-IO-Socket-INET6.noarch 0:2.54-1.el5.rf set to be updated
    ---> Package nss_ldap.i386 0:253-13.el5_2.1 set to be updated
    ---> Package lftp.x86_64 0:3.7.3-1.el5.rf set to be updated
    ---> Package perl-HTML-Tagset.noarch 0:3.20-1.el5.rf set to be updated
    ---> Package libxslt.x86_64 0:1.1.17-2.el5_2.2 set to be updated
    ---> Package perl-Compress-Zlib.noarch 0:2.011-1.el5.rf set to be updated
    --> Processing Dependency: perl(IO::Compress::Gzip::Constants) >= 2.011 for package: perl-Compress-Zlib
    --> Processing Dependency: perl(IO::Uncompress::Gunzip) >= 2.011 for package: perl-Compress-Zlib
    --> Processing Dependency: perl(IO::Compress::Gzip) >= 2.011 for package: perl-Compress-Zlib
    --> Processing Dependency: perl(Compress::Raw::Zlib) >= 2.011 for package: perl-Compress-Zlib
    --> Processing Dependency: perl(IO::Compress::Base::Common) >= 2.011 for package: perl-Compress-Zlib
    ---> Package perl-Net-SSLeay.x86_64 0:1.32-1.el5.rf set to be updated
    ---> Package cadaver.x86_64 0:0.22.5-1.el5.rf set to be updated
    ---> Package udftools.x86_64 0:1.0.0b3-3.el5.rf set to be updated
    ---> Package spamassassin.x86_64 0:3.2.5-1.el5.rf set to be updated
    ---> Package perl-IO-Zlib.noarch 0:1.09-1.el5.rf set to be updated
    ---> Package perl-Net-DNS.x86_64 0:0.63-1.el5.rf set to be updated
    ---> Package perl-DBI.x86_64 0:1.605-1.el5.rf set to be updated
    --> Processing Dependency: perl(RPC::PlServer) >= 0.2001 for package: perl-DBI
    --> Processing Dependency: perl(RPC::PlClient) >= 0.2000 for package: perl-DBI
    ---> Package syslinux.x86_64 0:3.71-1.el5.rf set to be updated
    --> Processing Dependency: perl(Crypt::PasswdMD5) for package: syslinux
    ---> Package subversion.x86_64 0:1.5.1-0.1.el5.rf set to be updated
    ---> Package perl-Archive-Tar.noarch 0:1.38-1.el5.rf set to be updated
    ---> Package dkms.noarch 0:2.0.20.2-2.el5.rf set to be updated
    ---> Package mtr.x86_64 2:0.72-1.el5.rf set to be updated
    ---> Package libxslt-python.x86_64 0:1.1.17-2.el5_2.2 set to be updated
    ---> Package rsync.x86_64 0:3.0.3-1.el5.rf set to be updated
    ---> Package nfs-utils.x86_64 1:1.0.9-35z.el5_2 set to be updated
    ---> Package perl-Socket6.x86_64 0:0.20-1.el5.rf set to be updated
    --> Running transaction check
    ---> Package perl-Compress-Raw-Zlib.x86_64 0:2.011-1.el5.rf set to be updated
    ---> Package perl-Crypt-PasswdMD5.noarch 0:1.3-1.2.el5.rf set to be updated
    ---> Package perl-IO-Compress-Zlib.noarch 0:2.011-1.el5.rf set to be updated
    ---> Package perl-PlRPC.noarch 0:0.2020-1.el5.rf set to be updated
    --> Processing Dependency: perl(Net::Daemon) for package: perl-PlRPC
    --> Processing Dependency: perl(Net::Daemon::Log) for package: perl-PlRPC
    --> Processing Dependency: perl(Net::Daemon::Test) for package: perl-PlRPC
    ---> Package perl-IO-Compress-Base.noarch 0:2.011-1.el5.rf set to be updated
    --> Running transaction check
    ---> Package perl-Net-Daemon.noarch 0:0.43-1.el5.rf set to be updated
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    =============================================================================
     Package                 Arch       Version          Repository        Size
    =============================================================================
    Updating:
     cadaver                 x86_64     0.22.5-1.el5.rf  rpmforge          165 k
     dkms                    noarch     2.0.20.2-2.el5.rf  rpmforge           61 k
     iftop                   x86_64     0.17-1.el5.rf    rpmforge           46 k
     lftp                    x86_64     3.7.3-1.el5.rf   rpmforge          2.7 M
     libxslt                 x86_64     1.1.17-2.el5_2.2  updates           488 k
     libxslt-python          x86_64     1.1.17-2.el5_2.2  updates           136 k
     mtr                     x86_64     2:0.72-1.el5.rf  rpmforge           81 k
     nfs-utils               x86_64     1:1.0.9-35z.el5_2  updates           386 k
     nss_ldap                i386       253-13.el5_2.1   updates           1.4 M
     perl-Archive-Tar        noarch     1.38-1.el5.rf    rpmforge           56 k
     perl-BSD-Resource       x86_64     1.2901-1.el5.rf  rpmforge           57 k
     perl-Compress-Zlib      noarch     2.011-1.el5.rf   rpmforge           34 k
     perl-DBI                x86_64     1.605-1.el5.rf   rpmforge          871 k
     perl-HTML-Parser        x86_64     3.56-1.el5.rf    rpmforge          149 k
     perl-HTML-Tagset        noarch     3.20-1.el5.rf    rpmforge           14 k
     perl-IO-Socket-INET6    noarch     2.54-1.el5.rf    rpmforge           16 k
     perl-IO-Socket-SSL      noarch     1.13-1.el5.rf    rpmforge           47 k
     perl-IO-Zlib            noarch     1.09-1.el5.rf    rpmforge           16 k
     perl-Net-DNS            x86_64     0.63-1.el5.rf    rpmforge          279 k
     perl-Net-SSLeay         x86_64     1.32-1.el5.rf    rpmforge          310 k
     perl-Socket6            x86_64     0.20-1.el5.rf    rpmforge           48 k
     rsync                   x86_64     3.0.3-1.el5.rf   rpmforge          370 k
     spamassassin            x86_64     3.2.5-1.el5.rf   rpmforge          1.1 M
     subversion              x86_64     1.5.1-0.1.el5.rf  rpmforge          5.7 M
     syslinux                x86_64     3.71-1.el5.rf    rpmforge          1.1 M
     udftools                x86_64     1.0.0b3-3.el5.rf  rpmforge          100 k
    Installing for dependencies:
     perl-Compress-Raw-Zlib  x86_64     2.011-1.el5.rf   rpmforge          172 k
     perl-Crypt-PasswdMD5    noarch     1.3-1.2.el5.rf   rpmforge          9.9 k
     perl-IO-Compress-Base   noarch     2.011-1.el5.rf   rpmforge           56 k
     perl-IO-Compress-Zlib   noarch     2.011-1.el5.rf   rpmforge          142 k
     perl-Net-Daemon         noarch     0.43-1.el5.rf    rpmforge           44 k
     perl-PlRPC              noarch     0.2020-1.el5.rf  rpmforge           33 k
    
    Transaction Summary
    =============================================================================
    Install      6 Package(s)
    Update      26 Package(s)
    Remove       0 Package(s)
    
    Total download size: 16 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/7): nfs-utils-1.0.9-35 100% |=========================| 386 kB    00:00
    (2/7): libxslt-python-1.1 100% |=========================| 136 kB    00:00
    (3/7): dkms-2.0.20.2-2.el 100% |=========================|  61 kB    00:00
    (4/7): subversion-1.5.1-0 100% |=========================| 5.7 MB    00:26
    (5/7): syslinux-3.71-1.el 100% |=========================| 1.1 MB    00:04
    (6/7): libxslt-1.1.17-2.e 100% |=========================| 488 kB    00:00
    (7/7): nss_ldap-253-13.el 100% |=========================| 1.4 MB    00:00
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    
    
    Transaction Check Error:
      file /usr/share/emacs/site-lisp/psvn.el from install of subversion-1.5.1-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
      file /usr/share/man/man1/svn.1.gz from install of subversion-1.5.1-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
      file /usr/share/man/man1/svnadmin.1.gz from install of subversion-1.5.1-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
      file /usr/share/man/man1/svnlook.1.gz from install of subversion-1.5.1-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
      file /usr/share/man/man5/svnserve.conf.5.gz from install of subversion-1.5.1-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
      file /usr/share/man/man8/svnserve.8.gz from install of subversion-1.5.1-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
      file /usr/share/xemacs/site-packages/lisp/psvn.el from install of subversion-1.5.1-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
    
    Error Summary
    -------------
    How can I fix this ? Thank you.

  2. #2
    Try to remove "subversion" if you do not use that package.

    yum remove subversion

    and after that try again:

    yum update
    ---=== RoseHosting.com Admin ===---
    Linux Cloud Hosting - linuxcloudvps.com
    Linux VPS Hosting - rosehosting.com
    High Quality Linux virtual servers with lots of Guaranteed RAM and HDD space, Impeccable Service.

  3. #3
    Join Date
    Jan 2005
    Posts
    483
    Thank you, it helped, also there were no dependencies for subversion so hope it'll be ok.

  4. #4
    Yes, if you do not use subversion, everything should be ok.
    ---=== RoseHosting.com Admin ===---
    Linux Cloud Hosting - linuxcloudvps.com
    Linux VPS Hosting - rosehosting.com
    High Quality Linux virtual servers with lots of Guaranteed RAM and HDD space, Impeccable Service.

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •