Results 1 to 5 of 5
  1. #1
    Join Date
    May 2001
    Location
    WA, USA
    Posts
    319

    MySQL RaQ3. My Misery

    I am wondering if I should reinstall MySql on my Raq3, because I am following all the instructions to get started but get nothing but errors.

    I SSH'd in and SU'd as root, then tried :

    mysql -h host -u user -p
    and entered the password when prompted, but got :

    ERROR 1045: Access denied for user: [email protected]' (Using password: YES)
    -------------
    mysqladmin -u root create mydb

    returns :

    Access denied for user: [email protected]' (Using password: NO)

    -------------

    mysql

    returns :

    Access denied for user: [email protected]' (Using password: NO)
    ----------


    I tried all the solutions from a similar thread, and nothing seemed to make this work. I even tried to reset permissions as specified in http://www.mysql.com/doc/en/Resetting_permissions.html but i just can't seem to get anywhere after deleting the .pid file.

    should I uninstall MySQL and install it again? If so, where can I find the .pkg for it? I currently have MySQL 3.23.37-1

    I apologize for the vague nature of this post, it's just that I'm not even sure what these commands are supposed to do in the first place.
    http://printers.abbey-lane.com

  2. #2
    Join Date
    Jan 2001
    Location
    Netherlands
    Posts
    236
    why would you use the host thing when mysql is running on localhost? This should work just fine:
    mysql -u root -ppassword
    And yep, no space between -p and password.

    And you're not entering a password with the mysqladmin command:
    mysqladmin -u root -ppassword create mydb
    Hmm, what does this do... Oops!

  3. #3
    Join Date
    May 2001
    Location
    WA, USA
    Posts
    319
    Hi pingu, I still seem to be having the same problem :


    [[email protected] admin]# mysql -u root -ppassword
    ERROR 1045: Access denied for user: [email protected]' (Using password: YES)
    [[email protected] admin]# mysqladmin -u root -ppassword create mydb
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user: [email protected]' (Using password: YES)'
    http://printers.abbey-lane.com

  4. #4
    Join Date
    Jan 2001
    Location
    Netherlands
    Posts
    236
    Hmm, it's password thing, and you couldn't get anywhere after killing the pid? Maybe the path to mysqladmin was wrong...
    What if you try these commands:

    /usr/bin/mysqladmin -u root -p password 'new-password'
    /usr/bin/mysqladmin -u root -h www.yoursite.com -p password 'new-password'

    Change new-password to the desired password
    Change www.yoursite.com to the main site name


    Hope that helps. If not maybe a mysql restart:
    /etc/rc.d/init.d/mysql stop
    /etc/rc.d/init.d/mysql start
    Hmm, what does this do... Oops!

  5. #5
    hey hey
    I am having the same problem, tried the pingu's tips, still couldn't fix it, any help?
    Strange that mysql is working alright on http , I actually just need to access via telnet to give permission to the database, mysql was alright few days ago, this problem happened un-expectedly x_x

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •