Results 1 to 11 of 11
  1. #1
    Join Date
    Jun 2008
    Posts
    36

    Can you disable email in linux?

    I have alot of mail spam for my servers and I want to disable mail alltogether. I don't really need it, for I'm mostly using free mail. How do I do it? Is this possible?
    Thanks.

  2. #2
    Join Date
    Sep 2007
    Location
    Vijayawada
    Posts
    185
    Which OS?
    Which mailserver software is it running?
    Using any control panel?
    Do you have shell access to the server?
    TUXG Hosting - shared hosting simplified
    Linux | BSD ~ Joomla | Drupal
    o 99.9% Uptime o Anytime Phone Support o 30-day Moneyback

  3. #3
    Join Date
    Jun 2008
    Posts
    36
    Hi,

    CENTOS Enterprise 4.6 i686 on standard - WHM X v3.1.0

    Exim I believe for mail

    WHM 11.15.0 cPanel 11.18.6-S24739

    Yes I do.

  4. #4
    Join Date
    Oct 2007
    Posts
    1,902
    If you don't want exim, you can disable it from WHM -> Service Manager -> Uncheck Exim and Save.
    ServerPoint.com - a true hosting company offering online presence solutions since 1998.
    >>Web Hosting, colocation, dedicated servers and virtual private dedicated servers.
    >>>>Wholly owned multi homed network, servers and facilities.

  5. #5
    Join Date
    Jun 2008
    Posts
    36
    Disabling exim, I'm getting spam emails though no? I want to disable mail completely, ie. not getting any incoming mail.

  6. #6
    yum remove your mailserver then.

  7. #7
    Join Date
    Jun 2008
    Posts
    1,471
    Disabling exim, aka stopping the service and not having it startup on boot will cause you not to receive any emails on the machine.

    You need not uninstall it, as stopping the service is enough.

  8. #8
    Join Date
    Mar 2006
    Posts
    241
    Remove exim service from chkconfig also

    chkconfig --del exim
    LiquidSupport - A subsidiary of I-Fort Technologies (Pvt.) Ltd
    Server Administration | Technical Support | Web Development

  9. #9
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,743
    You should block the SMTP port 25 on the server firewall. Once this is done no mail server related communication will be entertained by your server.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  10. #10
    Join Date
    Jun 2008
    Posts
    36
    I disable Exim and it seem to work.

    Is disabling Exim same as firewall? cause Exim is not getting mail anyway.


    "Remove exim service from chkconfig also

    chkconfig --del exim"

    Do I need to do that? since Exim is working.

  11. #11
    Join Date
    Aug 2007
    Location
    Providence, UT
    Posts
    894
    Just close port 25 on the server and no mail, in or out will be allowed.
    Kody
    Sr. Operations Analyst
    100TB.com -> Awesome dedicated servers. Check out our server outlet!
    VPS.NET -> Cloud Hosting. 18 Locations. Check out our website!

  12. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •