Results 1 to 6 of 6
  1. #1

    problem with phpmyadmin

    I have many problem with the configuration of phpmyadmin with raq550
    The error is: Can't connect to local MySQL server through socket '/var/lib/mysql' (13)

    Anyone help me!


  2. #2
    Join Date
    Jul 2002
    Cleveland, Oh USA
    Is the MySQL server actually running?

  3. #3
    Join Date
    Jan 2001
    the Netherlands
    Well my problem is to simular to start a new thread i don't mean to steal yours staff

    I have manually put mysql to live on my new raq550 (why isn't it standard running?).

    Unfortunatly phpmyadmin is not working, i cannot login (password wrong although it is right i checked it with ssh).

    i cannot create a database with some little utility that i use for all my raq4's and 3's.

    I took a look at phpinfo and find no information for mysql, only in the "configure command" --with-mysql=shared'
    but no other information on sockets etc.

    Does anyone have any clues?

  4. #4
    Join Date
    Apr 2002
    Hy people...

    I got the same problems with my RaQ550.

    This is what you have to do.

    SSH the RaQ550
    su root

    /etc/init.d/mysql stop (to be sure mysql is off)

    /etc/init.d/mysql start --skip-grant-tables

    (Now you have access to MySQL without having to give a password.)

    (Now start MySQL)


    -> GRANT ALL PRIVILEGES ON *.* TO "root"@"localhost"
    -> IDENTIFIED BY "the_new_password";

    change the_new_password to your password you like for MySQL, but NOT YOUR SERVERS ROOT PASSWORD !!!!

    exit (to quit the MySQL prompt)

    ln -s /var/lib/mysql/mysql.sock /tmp/mysql.sock

    (creates symbolic link)

    /etc/init.d/mysql stop
    /etc/init.d/mysql start

    From now you can enter MySQL only using password...

    mysql -uroot -pYOURPASSWORD

    here you can start creating databases....

    Now we're adding PHP - MySQL support to Apache:
    pico /etc/httpd/php.ini

    add this line somewhere:

    Now we're restarting apache with the new settings from php.ini..
    /etc/init.d/httpd restart

    phpMyAdmin should work from now...
    If not, tell me...
    Last edited by FiberOptic; 08-27-2002 at 05:48 PM.

  5. #5
    Join Date
    Jan 2001
    the Netherlands
    Thanks Fiberoptic, gonna try it right away.

    Now can anyone tell me why i have to do all this on my "out of the box ready to host perfect server appliance" to make things work?

    If you want to make normal use of your Sun appliance you first have to void the warranty!

  6. #6
    Join Date
    Apr 2002

    Some things I got from Sun's knowledgebase...
    Cause standard MySQL isn't available to PHP in the virtual sites httpd server...

    But the rest...
    It was hours searching
    Last edited by FiberOptic; 08-28-2002 at 09:03 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts