Results 1 to 5 of 5
  1. #1

    PhpMyAdmin and Permissions

    I just installed PhpMyAdmin on my RaQ 4 and was having some problem trying to configure MySQL.

    At root access, I can see all tables of all database which is great. But at user level, I want to be able to only expose the database which is related to them, how do I do it ? They keep showing all all databases which sort of defeats the purpose.

    Is there a way to associate a database to a specific User and without showing them to others ?

    Thanks. - Offering Batch Image Processing and TIFF/PDF Software Solutions

  2. #2
    Join Date
    Oct 2001
    Ann Arbor, MI U.S.A.
    If you follow the Documentation.txt file regarding http authentication and setup a phpMyAdmin mysql user it will work just as you want it too. Just set 'auth_type' to http and 'controluser' and 'controlpass' to the user you gave access to your mysql tables for phpMyAdmin (read the Doc.txt about exactly how to give the phpMyAdmin user access).

    Chris Wells [clwells - at -]
    Nexcess - Beyond Hosting
    Dearborn, MI DC ● Southfield, MI DC
    Wordpress Hosting, Magento Hosting & More!

  3. #3
    Thanks. I did not realized that there was any documentation which came with it. I got the file as a PKG file and installed it as a PKG file. I will try to hunt it down. Thanks again. - Offering Batch Image Processing and TIFF/PDF Software Solutions

  4. #4
    Join Date
    Jul 2002
    Atlanta, Georgia
    simply run this on the database "mysql" (changing the username and passwords in bold)

    GRANT USAGE ON mysql.* TO 'username'@'localhost' IDENTIFIED BY 'password';
    GRANT SELECT (Host, User, Select_priv, Insert_priv, Update_priv, Delete_priv, Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv, File_priv, Grant_priv, References_priv, Index_priv, Alter_priv) ON mysql.user TO 'username'@'localhost';
    GRANT SELECT ON mysql.db TO 'username'@'localhost';
    GRANT SELECT (Host, Db, User, Table_name, Table_priv, Column_priv) ON mysql.tables_priv TO 'username'@'localhost';
    and then open up, setting the control user and password, and also set the authtype to http as said.

  5. #5
    Thanks. I will do that. - Offering Batch Image Processing and TIFF/PDF Software Solutions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts