Results 1 to 26 of 26
  1. #1
    Join Date
    Aug 2002
    Location
    everywhere
    Posts
    6

    Outdated host using outdated software

    How hard is it for a webhost to update php using ensim?

    My current host thinks php installed a year ago is fine the way it is and sees no need to update the software. Their motto is if it ain't broke don't fix it. Can anyone post some help on exactly how to update php just in case the company is reading these forums since WebHostingTalk is one of the primary places they solicit at. Scripts have been verified to function only under the latest php release.

    Watch this space for the name of the company in the coming days if nothing is done to fix the problem.

  2. #2
    Why don't you ask them to update the software

  3. #3
    Join Date
    Aug 2002
    Location
    everywhere
    Posts
    6
    They said they would get to it and I keep waiting. Can I update php myself?

  4. #4
    While I agree with the "if it ain't broke, don't fix it" motto, PHP prior to version 4.2.2 is broke! There is a security vulnerability in some versions of PHP. The story is here: http://www.php.net/release_4_2_2.php

    However, regarding how easy it is to upgrade. It usually takes about 30 minutes. I am running 4.2.2 on my ensim box. Good luck with your requests. However, I don't think posting their name here is much leverage. If they are unwilling to accomodate you, vote with your pocketbook....move on.

    Good luck.
    *AlphaOmegaHosting.Com* - Hosting since 1998
    Managed Dedicated Servers and VPS
    Hosted Exchange 2010 Email Service

  5. #5
    Join Date
    Aug 2002
    Location
    everywhere
    Posts
    6
    As long as I save other people from the grief of having to deal with this company's lack of support. I didn't know about php needing to be update until I had multiple emails with the company that created the scripts questioning whether I was using the latest php or older versions.

  6. #6
    Well typically hosts shouldn't go about upgrading PHP anytime there is a new version, because it could just as easily break customers scripts as it might make yours work. But if there are security reasons, it should be upgraded immediately. If they have bad support, you should move. If you wanted to stay with them, you might ask if they have a server with the newer version they could move you to.
    *AlphaOmegaHosting.Com* - Hosting since 1998
    Managed Dedicated Servers and VPS
    Hosted Exchange 2010 Email Service

  7. #7
    What version of PHP are they running?
    Gary King

  8. #8
    Yes.Hosting company should choose a new and stable version.

  9. #9
    Join Date
    Aug 2002
    Location
    everywhere
    Posts
    6
    PHP Version 4.0.6
    ensim 2.4
    Apr 2001

    Does that look right?

  10. #10
    Join Date
    Apr 2002
    Location
    Philadelphia
    Posts
    2,277
    Its not that old I wonder how many security holes are in the version?

  11. #11
    Looks like standard ensim issue to me. How long have you been waiting?
    *AlphaOmegaHosting.Com* - Hosting since 1998
    Managed Dedicated Servers and VPS
    Hosted Exchange 2010 Email Service

  12. #12
    Have you check what version your Host is currently using? If you haven't done it , I would suggest creating a file phpinfo.php and upload it to the server.

    Recall the file and you should be able to see a long page full of system and enviroment information. This information is very helpful when you are trying to figure out what's available to you.

    Regards.
    WHO AM I? CLICK HERE!

  13. #13
    Join Date
    Aug 2002
    Location
    everywhere
    Posts
    6
    Long enough dandanfirema

  14. #14


    So, like I said before, vote with your money...if they don't serve you, find someone who will.
    *AlphaOmegaHosting.Com* - Hosting since 1998
    Managed Dedicated Servers and VPS
    Hosted Exchange 2010 Email Service

  15. #15
    Join Date
    Aug 2002
    Location
    everywhere
    Posts
    6
    Ok I have a question how come none of you guys here on WHT show up in Google under features I'm looking up. I only found about 150 sites that matched these keywords gb "unlimited subdomains" ftp php mysql -reseller. I would figure a webhosting company to design a site best suited for the internet.

    http://www.google.com/search?q=gb+%2...seller&num=100

  16. #16
    Join Date
    Jun 2000
    Location
    Washington, USA
    Posts
    5,991
    I saw a few on the first page of search results that post here.

  17. #17
    Join Date
    Sep 2001
    Posts
    1,310
    Ah, that would be because the word reseller is not on our site

    And although I'm running 6 paid google ads the word "unlimited" is listed as a negative keyword so ... no go.

  18. #18
    Join Date
    Aug 2002
    Location
    Beautiful suburb of Chicago
    Posts
    141
    It's also important to understand that there are two versions of Ensim's WEBppliance. The standalone version is easier to hack than the ServerXchange version. If your host is using SX, I agree with Dan about asking them if they can move you to one of their other servers that has the version of PHP you want. If they can't accomodate you, you should understand that bargain that comes along with virtual hosting is that you usually can't be the one telling the bus driver where to drive the bus. Changes to perl/modules/php on virtual hosting machines can very easily ruin the ride for a lot of other people riding the same bus you are.

    I should avoid analogies this early in the morning.

    George
    George Vuckovic - CEO & President, Tilted Planet, Ltd.
    Dedicated Servers, Dedicated Service, Definitely Tilted.
    Celebrating 16 years of top-notch hosting and innovation!
    Visit our 13 year old, obviously ancient site at TILTED.COM

  19. #19
    Join Date
    Nov 2000
    Location
    San Diego
    Posts
    3,407
    Originally posted by tilted
    It's also important to understand that there are two versions of Ensim's WEBppliance. The standalone version is easier to hack than the ServerXchange version.
    What are you talking about? You may want to clarify, because as it stands this is a rediculous statement.

    Originally posted by jennifer55
    Ok I have a question how come none of you guys here on WHT show up in Google under features I'm looking up.
    Maybe because there are over 18,000 web host in the world and WHT host make up a small fraction. Plus many of the host who come hear are just starting out.

  20. #20
    Join Date
    Aug 2002
    Location
    Louisiana
    Posts
    396
    PHP 4.2.2 released in response to vulnerability

    [22-Jul-2002] The PHP Group today announced the details of a serious vulnerability in PHP versions 4.2.0 and 4.2.1. A security update, PHP 4.2.2, fixes the issue. Everyone running affected versions of PHP is encouraged to upgrade immediately. The new 4.2.2 release doesn't include other changes, so upgrading from 4.2.1 is safe and painless.
    i am sure all of that software is loaded with security holes

    Not good to old server versions on the servers, wonder if i could hunt down any exploits for that php version

    j/k

  21. #21
    Join Date
    Aug 2000
    Location
    NYC
    Posts
    6,627
    Originally posted by Pilgrim
    Ah, that would be because the word reseller is not on our site
    But the minus sign jennifer55 had in front of "reseller" in her query would mean that only pages without that word would be returned: "unlimited subdomains" ftp php mysql -reseller

    But you did hit on one thing: few of the WHT-prominent hosts will have the word "unlimited" on their sites, whether associated with subdomains or anything else.

    Also, jennifer55, by excluding "reseller" you'll be leaving out a lot of hosts that offer reseller plans. That is, they might have exactly what you want, but also offer reseller plans and have a link to a "reseller" page on a page that would have perfectly described what you're looking for. You wouldn't see those pages using the above query.
    Specializing in SEO and PPC management.

  22. #22
    Join Date
    Nov 2001
    Location
    Ann Arbor, MI
    Posts
    2,978
    Originally posted by Pilgrim
    Ah, that would be because the word reseller is not on our site

    And although I'm running 6 paid google ads the word "unlimited" is listed as a negative keyword so ... no go.
    We had "unlimited" and "free" as negative when we used google's adwords.
    -Mark Adams
    www.bitserve.com - Secure Michigan web hosting for your business.
    Only host still offering a full money back uptime guarantee and prorated refunds.
    Offering advanced server management and security incident response!

  23. #23
    In terms with the PHP, I am happy with most of the releases after 4.1. Haven't had any security problems, and I like thos better than 4.2* because with 4.2+ you have to define form variables as $_GET[variable] instead of just $variable. If you really feel that you need the upgrade, see if your host will do it, otherwise if it were me I would stick with 4.0-4.1.

  24. #24
    Join Date
    Aug 2001
    Location
    North Carolina
    Posts
    32
    Ensim servers are the pits when it comes to upgrading things like PHP. We've got one that we won't touch. We've been flat out told that Ensim has to release a build for it, which they are slow to do. It isn't the host on this one, they're telling you straight. It is frustrating...
    D Unthank
    AFN Host - High Quality, High Value Linux Hosting
    Integra Hosting - HSphere Reseller Hosting

  25. #25
    Thats not entirely true. Some things can be updated without problems. We are running PHP 4.2.2 on an ensim 3.0 box.
    *AlphaOmegaHosting.Com* - Hosting since 1998
    Managed Dedicated Servers and VPS
    Hosted Exchange 2010 Email Service

  26. #26
    Originally posted by ikellen
    In terms with the PHP, I am happy with most of the releases after 4.1. Haven't had any security problems, and I like thos better than 4.2* because with 4.2+ you have to define form variables as $_GET[variable] instead of just $variable. If you really feel that you need the upgrade, see if your host will do it, otherwise if it were me I would stick with 4.0-4.1.
    If you want, you can turn it off in 4.0.6(+) as easy as you can turn it on in 4.2+
    This doesn't make any sense...
    Web-cp: an open source control panel: http://www.web-cp.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •