Results 1 to 3 of 3
  1. #1

    Apache2 hangs the VPS up

    Hello. I'm new to this forum.

    I have a problem. When MSN Search robot looks through my VPS, the machine is going "asleep", e.g. Apache2 (Port 80) doesn't answer at all. Here is the last falling:
    Code:
     23:14:15 up 4 days,  9:06,  5 users,  load average: 37.18, 31.25, 27.46
    I hardly ever can enter 'pkill apache2' to kill Apache2 processes. Here is my Apache2 configuration (timeouts, prefork, e.g.):

    Code:
    Timeout 30
    KeepAlive On
    MaxKeepAliveRequests 20
    KeepAliveTimeout 5
    
    <IfModule mpm_prefork_module>
        StartServers          2
        MinSpareServers       2
        MaxSpareServers       5
        MaxClients           10
        MaxRequestsPerChild 400
    </IfModule>
    Maybe I configured Apache2 wrongly, but I only want to prevent this bad thing.

  2. #2
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    You can try increasing the MaxClients value.

    Is there lot of time_wait requests?

    netstat -plan | grep TIME_WAIT
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  3. #3
    Thanks, david510. I'll try to increase MaxClients.
    Maybe, i'll setup nginx... Can it resolve the problem?

    There are lots of time_wait requests, but they are not for Apache (other ports).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •