Results 1 to 8 of 8
  1. #1

    DreamWeaver 1045 error MySQL

    When trying to connect to my database with DW, I get this error.
    Access denied for user eyead_nitro'@'localhost (using password: YES)
    I have spent many hours scouering the forums to try and fix this but nothing has worked. Please help!
    Here are the screenshots of everything and links to related sites with info I found.
    I followed this site to a T! It got me this far but no connection :-(

    (http://paul.ecommerce.hct.ac.ae/tuto...hp/dwmxphp.htm)

    And these are the screenshots of my CPanel and DW settings

    http://i11.photobucket.com/albums/a1...bleshoot/1.jpg
    http://i11.photobucket.com/albums/a1...hoot/77720.gif
    http://i11.photobucket.com/albums/a1...hoot/77721.gif
    http://i11.photobucket.com/albums/a1...hoot/77722.gif
    http://i11.photobucket.com/albums/a1...hoot/77723.gif
    http://i11.photobucket.com/albums/a1...hoot/77724.gif
    http://i11.photobucket.com/albums/a1...hoot/77725.gif
    http://i11.photobucket.com/albums/a1...hoot/77726.gif
    http://i11.photobucket.com/albums/a1...hoot/77727.gif
    http://i11.photobucket.com/albums/a1...hoot/77728.gif
    http://i11.photobucket.com/albums/a1...hoot/77729.gif
    http://i11.photobucket.com/albums/a1...hoot/77730.gif
    http://i11.photobucket.com/albums/a1...hoot/77731.gif

    Thanks in advance for any help.

  2. #2
    Join Date
    May 2007
    Location
    Canada
    Posts
    183
    You are receiving that error because your trying to access your database on your home computer, which does not have mysql running on it. Your 'localhost' is your computer. Most web servers do not allow connections from outside sources to access the sql server, thus the reason they use 'localhost', as it querying itself. You have a couple of options, install sql on your development box, get your host to modify the mysql config to allow you to query it from outside the localhost, or, upload your files to your server, then try them.
    Quality Hosting - http://www.robohostingsolutions.com
    My Blog - http://solidservers.ca
    Freelance Server Administration (decent rates!) - Chris(at)SolidServers.ca

  3. #3
    I have MySql 5.0 installed on this computer.

  4. #4
    Join Date
    Oct 2004
    Location
    Shimonoseki
    Posts
    2,101
    On these pictures, you are creating a database on a cPanel, which is a remote web server. You have to create same database and user in your own computer too.

    I strongly recommend uninstall all php and mysql from your computer, and install WampServer http://www.wampserver.com/en/
    It will install apache, php, mysql and mysql drivers, phpmyadmin.

    From there, you can run phpmyadmin, and add new databases and users easily.
    Closed for winter...

  5. #5
    Will I be able to connect with DW after that??
    Thanks...I will install WampServer. I will need WampServer for dummies after that. LoL
    ty

  6. #6
    Join Date
    Oct 2004
    Location
    Shimonoseki
    Posts
    2,101
    Quote Originally Posted by n1tr0 View Post
    Will I be able to connect with DW after that??
    Thanks...I will install WampServer. I will need WampServer for dummies after that. LoL
    ty
    OK, re-reading your post, and the guide you posted, I think you don't need the Wamp server at all.

    According to that article, you should be able to connect your cPanel database by using "localhost" as your database host.

    If that is true (I never tried to connect a remote database with dreamweaver), than you must have something missing in your cPanel database setup. Here is a checklist:
    • Create the database
    • Create the user
    • Apply user to the database with all privileges

    Did you do all of the above?
    Closed for winter...

  7. #7
    Yes, I did it all. I even re-did it all 3 times. I deleted the user, changed name to nitro instead of n1tro in case it didnt like numbers. the only thing I haven't done is change the password. as it stands, the user PW includes special characters (!@#$%...). I'm changing it and trying it again. Another thing, I saw this at a diff. post and am not sure what she meant by it...

    By:Kate
    a tip for others with this dilemma:

    go back to "Manage Sites" in dreamweaver. at the bottom, you MUST enter a URL prefix and http://yourdomain.com/ is not enough - it MUST point to the actual directory your dreamweaver site exists because that is where dreamweaver is looking for it's _mmServerScripts folder to make the actual connection. At this point, it's not even connecting "remotely" anymore so you can turn off remote access and use "localhost" as mentioned earlier in this thread.

    in fact, i'd be willing to bet you don't even have to set up a new user in cpanel (just use your existing db password.)

    good luck!

    just to test my theory - I switched my remote username to my original database username in dreamweaver, then removed wildcard remote access in cpanel - and my db connection still works great.

  8. #8
    another thing u all should know is that the site (checkthespot.com) is an adon to www.eyeadore.com wich is the main site on my cpanel account. It might not make any diff since _mmServerScripts/MMHTTPDB.php and /mysql.php are both present in the chethespot.com as well as the eyeadore.com root.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •